Forum Libraries, Components, and Plugins

Game does not work anymore after upgrade of Xamarin Studio to "Indie" license


I was happy with Xamarin Studio trial license running on Windows, did some development on top of BouncingGame example. It worked just perfect and then I decided to purchase Indie license. I wasn't smart enough to understand how my license is going to be installed and used after the purchase, so decided simply to reinstall Xamarin Studio. And I did. However, during installation process I got error (which I found kind of common by searching in Internet) and it was suggested by installer to install necessary tools (Xamarin Studio and Xamarin) manually. I did, successfully.
Now I have Indie license working just fine, but not my game anymore. Xamarin says "[Choreographer] Skipped 290 frames! The application may be doing too much work on its main thread." and app shows black screen on the device. Always, rebuild/clean/reboot/pray/coffee in any combination does not help. I also tried to change my license back to Trial (successfully), but the game does not run with the same error. I tried to reinstall Xamarin, SDK, ..., everything (Xamarin installer still unable to install everything automatically and asks me to download and install packages manually) - no effect. I didn't see mentioned error message before, never - game was working fine, I swear. So I'm kinda in situation "I did nothing but it does not work anymore".
Please, I spent a day already... I'm thinking to reinstall Windows and the everything, somebody stop me...
Ah, and I also noticed that Xamarin sees my Android SDK installed in "C:\Users\Fedor Bushlanov\AppData\Local\Android\android-sdk". It is not the location where I did install it, since I did to "C:\Program Files (x86)\Android\android-sdk". However, if to change the location in Xamarin settings, it says "System.Diagnostics.Debugger.Mono_UnhandledException_internal...". Internet said better to use what what there originally (we all know the reasons, it's common problem, again), so I do.


  • FedorBushlanovFedorBushlanov VNMember ✭✭

    And once more thing. I downloaded original BouncingGame example and it does not work now too with the error attached. I also attached my SDK Manager config, what you see is the only I have installed (my device has API 16).

  • FedorBushlanovFedorBushlanov VNMember ✭✭

    OK. I figured it out and solved. BouncingGame example was not working because I set API 16 both to Minimum Android Version and Target Android Version, while target should be 17. Target Framework should be Android 4.2 too. After I changed settings it works. My stupidity and nothing much besides.
    Now my game, which was not working too. The real cause of the problem was CocosSharp version 1.3.0. Somehow it was updated from version 1.2.1 and I didn't notice it. So, with 1.3.0 all I see after my game deployed to a real device is "...The application may be doing too much work on its main thread." and a black screen. I changed CocosSharp to 1.2.1 and it works!!! I don't know why 1.3.0 gave me so much pain, but finally I'm still with 1.2.1 and happy.

Sign In or Register to comment.