Forum Visual Studio

Provisioning Problems for iOS Simulator

I'm running into the following problem. The apparent incongruity is that I'm trying to run on the iOS simulator but I'm getting asked about a provisioning profile, which I believe you only need to run on the device. Here is the output of the build log:

正在建置:BoxViewClock.iOS (Debug|iPhoneSimulator)

Detecting signing identity...

---------------------- 完成 ----------------------

No valid iPhone code signing keys found in keychain.
組建:1 錯誤, 0 警告

Version Info:

Xamarin Studio
Version 5.7 (build 660)
Installation UUID: ea1c8129-cb1f-459b-87d0-8c154ea39a64
    Mono 3.12.0 ((detached/a813491)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 312000068

Version: (Trial Edition)
Android SDK: /Users/nate/Library/Developer/Xamarin/android-sdk-macosx
    Supported Android versions:
        2.1    (API level 7)
        2.2    (API level 8)
        2.3    (API level 10)
        3.1    (API level 12)
        4.0.3  (API level 15)
        4.3    (API level 18)
        4.4    (API level 19)
        4.4.87 (API level 20)
        5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_20"
Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)

Apple Developer Tools
Xcode 6.1.1 (6611)
Build 6A2008a

Not Installed

Version: (Trial Edition)
Hash: 2c57f4e
Build date: 2014-12-18 16:42:49-0500

Build Information
Release ID: 507000660
Git revision: 6a74f9bdb90d9415b597064d815c9be38b401fee
Build date: 2014-12-18 00:38:00-05
Xamarin addins: 57be0f5e1433cb58b70ea9b52e9dc77ad791be40

Operating System
Mac OS X 10.10.1
Darwin natedembp 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64


  • NathanGuerinNathanGuerin USMember

    @jstedfast‌ I couldn't find an entitlements option anywhere, perhaps this is because I'm using the beta version of Xamarin Studio? Here's the General and advanced screens from iOS Build project options.

    I also searched for all plist files in the solution's directory and did not find an entitlements.plist. Could something else be going on?

    natedembp:BoxViewClock nate$ find . -name *.plist
    natedembp:BoxViewClock nate$ 
  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai
    edited January 2015

    Sorry, I meant the "iOS Bundle Signing" section, not "iOS Build".

  • NathanGuerinNathanGuerin USMember

    It's empty too :smile:

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Oh, you are running into the bug I fixed yesterday for Classic API builds.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Currently the only workaround is to get a codesigning key and provisioning profile from

  • NathanGuerinNathanGuerin USMember

    Thanks for the reply, I'll give it a shot and see how it turns out.

  • JosephFicaraJosephFicara USMember

    Adding the signing profile informaiton did appear to work for me. Do you know when the fix for this defect will be published in the stable build ring? I have several students taking a course I am teaching this semester that will be running into this.

    Best regards,

    Joe Ficara

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    it's in the beta channel right now, so I expect it to go to stable by the end of the week or very early next week.

  • JoeStroutJoeStrout USMember

    Sorry to kick open this old thread, but I'm running into exactly the same issue (my iOS Bundle Signing panel is completely empty), and my "Check for Updates" window says that I'm up to date (with the Stable channel). I'm running 5.10.1 (build 6), and I have the Indie license.

    I'm trying to resume development work I set aside a year or more ago. So it is, of course, using the classic API. The Mac version works fine, but the iOS version fails with "Error: No installed provisioning profiles match the installed iOS code signing keys." This is while trying to run in the simulator.

    @JeffreyStedfast, did that fix make it into 5.10.1? Any idea what might be going wrong here?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Yes, that fix made it into 5.10.1 - that patch went in about a year ago.

    Most likely your signing certificate and/or provisioning profile have expired (they only last for about a year).

    If you don't think that's the problem, what you will want to do is follow the directions to get a diagnostic build log:

    I'll need a copy of your build log as well as a copy of the file located at /Users/<user name>/Library/Xamarin/Provisioning Profiles.plist so that I can see the inputs provided to the code that tries to figure out what code signing key and provisioning profile to use so that I can figure out why it is failing to find it.

    Once you have those files, you can either email them to [email protected] or file a bug at (make sure to select "MSBuild" as the component).

  • IvanIcinIvanIcin USMember ✭✭✭

    Let me check if I've got this thread correctly in my case - if you want to use UIDocumentMenuViewController (iCloud), you need to set custom entitlements according to , so once you do that you can't test anymore on the simulator but only on the device?

  • TimurElzhovTimurElzhov USMember

    @IvanIcin I believe you can use doc picker on the simulator. There seems to be a bug in Xamarin so you have to explicitly select 'Entitlements.plist' file in the 'Custom Entitlements' input field. I didn't test that much though, but it allowed me to create a document picker instance at least.

  • IvanIcinIvanIcin USMember ✭✭✭

    @TimurElzhov yes, but now is a year later and simulator supports iCloud as far as I remember it wasn't the case one year ago. Just to say that I can confirm that it can work right now, which is the most important, but I don't think it worked when I was talking about that.

  • I was seeing the exact same problem on simulator . the way i fixed it was
    choose the iOS SDK as default
    rebuild the whole solution and make sure it shows all succeeded
    then change it back to iOS 12 this time around you should not see the error

Sign In or Register to comment.