Forum Xamarin.Android

My phone is not discovered as a device. [OnePlus One]

I was trying to debug my app with my new OnePlus One but it didn't get discovered. How do I solve this?


  • CheesebaronCheesebaron DKInsider, University mod

    Just like with every other device, you need to install the appropriate ADB drivers. Which ones to install for your device you can ask the manufacturer. You can also try the Google USB drivers, which you can download through the SDK manager.

  • LinusNeumanLinusNeuman SEMember

    Thank you, Cheesebaron, I will try to find the appropiate drivers. :)

  • Louis-GuillaumeLIMLouis-GuillaumeLIM USUniversity

    did you find it ?
    I'm looking for those drivers too.


  • LinusNeumanLinusNeuman SEMember

    I think I used the Google USB driver, you can download the android sdk and install that usb driver and then install it to your OnePlus One. Can you search for it? I don't have the time to find it for you right now. :)

  • Louis-GuillaumeLIMLouis-GuillaumeLIM USUniversity

    I already have this drivers, and I successfully debug on a Nexus5, but I can't debug on the OPO.
    I've tried to install the samsung latest driver as I read in other forum threads, but when I tried to change driver in W8, the message is always: "the current driver is better" or "already installed".

    I can't chose ADB driver in my driver list (it doesn't shows, not even the Samsung manufacturer).

    I tried the OPO toolkit but can't manage to do anything better.

    I'll try to post here if I find a clue.

  • rmaciasrmacias USBeta, University ✭✭✭✭✭
    edited January 2015

    Did you enable the Developer Options and application debugging on your OnePlus One settings? Also, if you "installed" it from the Android SDK Manager, you didn't really install it. You just downloaded it (yeah, I know it's the app is misleading). You actually have to navigate to the driver and install it manually.

  • CheesebaronCheesebaron DKInsider, University mod

    Drivers are installed per device. So you need to install drivers for your OPO as well.

    Any generic ADB driver should work for debugging.

  • Louis-GuillaumeLIMLouis-GuillaumeLIM USUniversity

    I solved it.
    My real problem was that I was trying to replace the "oneplus one" drivers in the device manager.
    The system would'nt let me do it no matter what driver I wanted to try.

    But i didn't see that another device was here : "A0001" and when I understood that this too was my OPO, I did the regular ADB driver install.
    It took me 30 seconds and it was OK.

    Conclusion : if you can see your OPO in the device manager and still can't debug, try to find another unrecognised device that could be it, and force the ADB driver on it.
    (you can unplug your OPO to check if this second device disappear at the same time to be sure).

    Hope it can help.

Sign In or Register to comment.