Cannot run template «Android Application»

I am noob in Xamarin

I downloaded and installed Xamarin, ran Visual Studio, chose «Android Application», started Android Emulator, chose running Android Emulator.
But this error ocurred:

System.NullReferenceException: object reference not set to an instance of an object

in Mono.VisualStudio.Extension.StatusBarHelper.get_IsFrozen()

in Mono.VisualStudio.Extension.StatusBarHelper.SetText(String text)

in Mono.Android.VisualStudio.MonoAndroidDeploySession.ShowProgressText(String text, CancellationToken token)

in Mono.Android.VisualStudio.MonoAndroidDeploySession.BuildAndSignPackage(CancellationToken token)

in Mono.Android.VisualStudio.MonoAndroidDeploySession.DeployApplication(AndroidDevice device, CancellationToken token)

in Mono.Android.VisualStudio.MonoAndroidDeploySession.OnDeploy()

What problem?

Posts

  • DominiqueLouisDominiqueLouis GBMember Xamurai
    edited March 2013

    Hi @OlegTarusov,
    Which version of Visual Studio are you using?

    D.

  • OlegTarusovOlegTarusov RUMember

    2010.

    I found some settings. I change Android 4.0 to Android 2.2, and emulator started
    But I cannot find my application in this emulator.

  • CheesebaronCheesebaron DKInsider, University mod

    It takes a little while to deploy the first time to an Android Emulator, so press Run and go out to take a cup of coffee, talk to some colleagues and when you return it should be done.

  • OlegTarusovOlegTarusov RUMember

    Thanks all. My problem was because the emulator has little memory.
    Problem is solved.

Sign In or Register to comment.