Oxyplot PCL installation problems

SampaioAndrSampaioAndr USMember
edited May 2014 in Visual Studio

Hi, I'm trying to install the Oxyplot.XamarinAndroid PLC, but when I try to install it through the Nuget Manager, It gives me this error while installing the Oxyplot.Core dependency.

Could not install package 'OxyPlot.Core 2014.1.308.1'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v4.1', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author. At line:1 char:1

Thanks in advance,
Andrew

Posts

  • mattwardmattward GBMember Xamurai

    OxyPlot.Core contains a PCL assembly so you should be able to install it into a MonoAndroid project if you have the Xamarin PCL profiles (Xamarin.Android.xml) installed. It looks like the OxyPlot.Core has a PCL that targets profile 88.

    Inside the following directory there should be some Xamarin.Android.xml files. They will not be directly inside it but further down inside some subdirectories. See if there are any files.

    C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework.NETPortable

    You could also try using a console app that lists all the profiles on your machine. You should see MonoAndroid next to list of profiles.

  • SampaioAndrSampaioAndr USMember

    Thanks for your reply.
    The problem was the nuget installation, reinstalled and the problems went away

  • AkinAkin USMember

    Hi Andre, when i use Nuget to download OxyPlot.core, i get a message saying "Oxyploy.Core could not be installed because it is not compatible with any project in the solution. The package targets the following frameworks. ,NetPortable, Version=v0.0, Profile =net4...."

    I confirmed I have the MonoAndroid files on my sytstem. Please, do you have any ideas on what is going on?

  • mattwardmattward GBMember Xamurai

    Make sure you have the latest version of NuGet installed if you are using Visual Studio.

    If there is still a problem can you post the full error message and what type of project you are installing it into?

  • FabienComteFabienComte FRMember

    Hello,
    Same problem since packages update...
    Could not install package 'OxyPlot.Core 2014.1.546'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v4.4', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

    Could someone help me please ?

  • mattwardmattward GBMember Xamurai

    You may not have the Portable Class Libraries installed or if you are using Visual Studio you may have an old version of NuGet installed (to upgrade NuGet in Visual Studio go to Extensions and Updates, Updates, Visual Studio Gallery).

Sign In or Register to comment.