Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Xamarin.Forms 1.3.1 page rendering odd for iOS devices larger than a 4S

I went through the migration process, both with the tool and manual. The app is building and looks fine on a 4S, however on a 5, 5S, 6, 6Plus (both in simulator and on actual devices) etc... the page seems to be rendering at a smaller size leaving a black bar at the top and bottom. See attached screenshot. The page I'm trying to load is a ContentPage.



  • FredrikHaglundFredrikHaglund SEUniversity, Developer Group Leader ✭✭
    edited December 2014

    Can you check if [email protected] launch image is included in the build.

    It is iOS magic and signals that you support 4 inch retina displays.

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    @FredrikHaglund‌ Yes, that launch image is present and part of the build.

  • MarkErickson.91MarkErickson.91 USMember ✭✭
    edited December 2014

    The MainPage property from the Application is set to a MasterDetailPage and then the app detects authentication is required and pushes the LoginPage using Navigation.PushModalAsync. Ive removed both the master detail and the modal and set the MainPage to a simple ContentPage. I ended up with the same results.

    I just don't know what mechanism is used to render these pages based on device / screen size. I'm at a loss, not sure where to look.

  • FredrikHaglundFredrikHaglund SEUniversity, Developer Group Leader ✭✭

    Try to delete the App from the simulator and deploy it again.

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    Tried that, didn't work. I also installed it on a factory reset 5S 8.1.2 and got the same result.

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    Just tried another app, a quick little demo app ( and I have the same result. So I must have missed something in my migration?

    Version info:
    Xamarin Studio
    Version 5.7 (build 660)
    Installation UUID: b01f5db8-fced-4ac3-9c2b-d7580e9d7a70
    Mono 3.12.0 ((detached/a813491)
    GTK+ 2.24.23 (Raleigh theme)
    Package version: 312000068

    Apple Developer Tools
    Xcode 6.1.1 (6611)
    Build 6A2008a

    Version: (Business Edition)
    Hash: 2c57f4e
    Build date: 2014-12-18 16:42:49-0500

    Version: (Business Edition)
    Android SDK: /Users/merickson/Library/Developer/Xamarin/android-sdk-mac_x86
    Supported Android versions:
    2.1 (API level 7)
    2.2 (API level 8)
    2.3 (API level 10)
    3.1 (API level 12)
    4.0 (API level 14)
    4.0.3 (API level 15)
    4.1 (API level 16)
    4.2 (API level 17)
    4.3 (API level 18)
    4.4 (API level 19)
    4.4.87 (API level 20)
    5.0 (API level 21)
    Java SDK: /usr
    java version "1.8.0_25"
    Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
    Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

    Not Installed

    Build Information
    Release ID: 507000660
    Git revision: 6a74f9bdb90d9415b597064d815c9be38b401fee
    Build date: 2014-12-18 00:38:00-05
    Xamarin addins: 57be0f5e1433cb58b70ea9b52e9dc77ad791be40

    Operating System
    Mac OS X 10.10.1
    Darwin Marks-MacBook-Pro.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64

  • FredrikHaglundFredrikHaglund SEUniversity, Developer Group Leader ✭✭

    There is no png launch image in the iOS project on the Github project you linked so it will not use the full screen.

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    But there is a png launch image on my app and I'm getting the same result. I'm not sure how the two are connected? I've got to be missing something so small.

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    I see the connection now, that image is required for the app to be full screen on iPhone 5. It's in the project file, so I'm not sure why I'm seeing this behavior.

  • ChaseFlorellChaseFlorell CAInsider, University mod

    have you added it in the iOS Project properties? I'm not 100% positive, but I think it updates the info.plist in order to instruct iOS that it exists.

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    I looked in the plist and I don't see any default launch png files, but I do see them in the project (edited as text) AND I see them in the project options under iOS Application . And I'll be honest, things were loading so fast I really never paid attention to the launch image, but I CAN say the launch image is NOT showing when the app is launched. This is a changed behavior since the migration to XF 1.3.1. I've looked in the app output, no exceptions were thrown, so I'm not sure why the launch image isn't loading. Grrrrr! :smile:

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    Ok, all of everyones help led me to the info.plist file. There were no launch images defined in that file. Is this a change with XF 1.3.1? Launch images were working perfectly before. Anyway, thanks to #CraigDunn blog ( I was able to edit the plist file and the launch images are back and the app is now full screen. Many thanks to everyone!

Sign In or Register to comment.