MonoMac: "The application has not been built"

I have a MonoMac project that is part of a bigger solution. When selecting the project as the start-up project and trying to launch it, it successfully builds the project but fails to launch it. Xamarin Studio shows the dialog "The application has not been built." Screenshot shown here

The application does run successfully from the terminal by navigating to the output directory and using mono Pipeline.exe.

Any ideas on what could cause this error? What are the conditions that trigger that dialog?


  • Steve_WilliamsSteve_Williams AUBeta ✭✭
    edited July 2014

    I'm using Protobuild to build the solution and project files, and had selected the wrong project type (GUI instead of App) and it had inserted <OutputType>WinExe</OutputType> into the csproj. Changing the project type to App in the Protobuild definition file so it generated <OutputType>Exe</OutputType> made things better.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Strange, I took a look at the code and it's only checking for the .app directory, which is determined from the AssemblyName project property. Maybe changing that setting caused some other properties to update automatically.

  • EricTheriaultEricTheriault USMember ✭✭

    I had this issue a few times; there seems to be an issue regarding changing the name of the target, changing the default namespace, or a project name with a "." in it. Not sure precisely what it is, but avoiding all of those allows it to work. Thanks.

  • My Unified API project suddenly started to exhibit this same issue, no matter how I edit the project name (I had spaces instead of dots in the name) or try to clean up the .csproj file I get the error message.

    And of course, nothing is shown in the actual Output that in any way relate to failing to build, build goes through just fine.

    Xamarin: this is damn frustrating, first you broke the Indie licensing and now still having these issues!

  • To add: it might be that this started after latest rounds of upgrades for Xamarin Studio, I'm not entirely sure. But it used to build before without error message (in fact, I managed to get it running with some solution config even with the current version but something happened and now none of the configs work).

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    FWIW, the Unified API projects use a completely new build system (based on MSBuild) which is why they are marked PREVIEW. We're still working out some kinks.

    If you could email [email protected] with your project files and repeat (or link) to your forum posts here explaining the issue, the Xamarin.Mac team can look into this issue more thoroughly.

  • The problem is that I'm a potential customer, I'm trying out Xamarin.Mac, I ended my trial early, and now I'm stuck with Starter, and I had to convert my project to Unified API and now I cannot run the project, because I get the "The program has not been built."

    Which it has been...

    What's going on??

  • Looks like the bug is in fact having a PERIOD or SPACE in the name of the executable. This will cause it to not execute at all.

    Once I removed the space from the executable (therefore screwing up the name of the app in the dock (because it shows the executable name in there), then it started launching.

    This is a bug in Xamarin.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    I've just pointed out Xamarin.Mac developers at this forum post, hopefully they can take a look.

  • ChrisHamonsChrisHamons USForum Administrator, Xamarin Team Xamurai

    Hey everyone,

    I can confirm this is a bug with the unified build system -

    -- Chris H

  • robkuzrobkuz DEMember

    It seems to me that the build with the "unified API" is completely broken for F# at the moment. Studio Version 5.5.4 (Build 15).

    If I create one solution and add 1 Empty F# projects into it (Unified API) than I get that error as described above

  • ChrisHamonsChrisHamons USForum Administrator, Xamarin Team Xamurai

    @Robkuz - I'll forward that to our F# guy to look at. Sorry for the trouble.

  • DaveThomasDaveThomas GBMember, Xamarin Team Xamurai

    I think the fix for this went into monotouch 8.6.0 , it was an issue with an msbuild target ordering in the file Xamarin.iOS.FSharp.targets

  • robkuzrobkuz DEMember

    When will 8.6.0 be released?

  • ctaggartctaggart USMember

    I just ran into this as well. Out of the box, this template doesn't work:
    OS X > Xamarin Studio > F# > iOS > Unified API > iPad > Empty Project

    /Developer/MonoTouch/usr/bin/mtouch --version
    mtouch (7244769)

    Is there a convenient way to get a build of 8.6.0?

  • GlennWester.4818GlennWester.4818 USXamarin Team Xamurai

    @ctaggart‌ Xamarin.iOS is in Beta right now, you can grab it by switching your Update Channel to 'Beta'.

  • MarkCapleMarkCaple USMember

    This is a problem when you are on a trial version as the latest appears to be (Trial Edition) and no matter how many times you try to update stable, beta or alpha you are told it is up to date.

    A small problem for people trialing as even a blank solution gives this "the application has not been built" error which sort of defeats the point of the trial. :)

  • WindelWindel USMember ✭✭

    I had the same issue for my Xamarin.iOS app. When building, no errors during build, but a popup was shown with "the application has not been built". The issue was that I had set my output path to "${SolutionDir}/bin". Changing this back to the default, fixed the issue. Looks like xamarin looks for the app file in the default output folder, not the one specified in the output path.

  • NicholasTurnerNicholasTurner USMember, University ✭✭

    I edited my project file and removed a silent failed build and it works

  • ChrisNurseChrisNurse AUMember ✭✭

    Tagging on the end of this older thread, just for future reference. I got the "The Application has not been built" error message. Just before that I'd deleted all the bin and obj folders from the projects in my solution. The way I eventually fixed it was just visiting the Preferences for each project in the solution. Doing so seemed to reset something and I was again able to rebuild and deploy to my device.

  • KeithBoyntonKeithBoynton GBMember ✭✭✭

    I just got the same "The application has not been built" error when switching from debugging using an iPhone simulator to an iPad simulator.

    I can confirm the suggestion above (viewing the options for each project) fixed it.

Sign In or Register to comment.