Forum Visual Studio

Has anyone been able to get 4.0.3 to work on Windows 8?

I was on 4.0 waiting for 4.0.2, got busy and then in the meantime 4.0.3 was released. I got unbusy so tried to upgrade. I started XS, was prompted to upgrade, attempted to do so, but received some error messages about an inability to find the installation source. I should have grabbed a screenshot because now after an uninstall and reinstall I am getting different error messages.

I can install 4.0, I can upgrade to 4.0.3, but when I start Xamarin Studio I get the following message:


If I say Yes, XS loads but when I try to open a file it opens in Visual Studio instead. If I close XS and then start it again, I get a different message and XS fails to start at all after that:


Multiple uninstall attempts, installer repair attempts, and manually cleaning the registry seem to produce the same results.

Any ideas? This is on my Windows 8 system. On a Windows 7 box, everything worked correctly and it's running 4.0.3.


  • mhutchmhutch USMember, Xamarin Team Xamurai

    Try removing AppData\Local\XamarinStudio-4.0\Cache\addin-db-001 from your user directory.

  • nerdzeronerdzero USMember

    Good idea but same results.

    Just went through the whole process again from the beginning and some strange things I just noticed in the updater.log file were these lines:

    Property(N): ROOTDRIVE = D:\
    Property(N): TARGETDIR = D:\

    I do have a D:\ drive but my root drive is C:\, I'm leaving the default installation target path, and I am installing from E:\Downloads\ so I'm not sure where it's getting D:\ from or if it even makes a difference.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    I'm at a loss then, it works fine on both my Windows 8 machines. It sounds like a problem with the installer.

    @lluis, do you have any ideas?

  • nerdzeronerdzero USMember

    Okay, well I copied over all the files in the Xamarin Studio folder from a working install on my other machine and now it works. Must have been gremlins.

Sign In or Register to comment.