Forum Visual Studio

Xamarin Updating from Xcode Changes

KevinMullinsKevinMullins USMember, Beta ✭✭

I'm having a dickens of a time getting Xamarin Studio to see that I've made changes in any of my Xcode projects/.xibs.

It usually includes, making a change in a .xib, saving, completely quitting Xcode, cleaning the Xamarin project, doing a full rebuild, launching the app as a demo in simulator, quitting the app in simulator, then Xamarin Studio sees the change and imports the updates from Xcode.

I almost always have to go through the above steps and its that way in all of my solutions.

Do you think you could add a menu option under Project to force Xamarin to reread the Xcode project??


  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    It's supposed to sync when Xamarin Studio regains focus. This is, however, an asynchronous operation that sometimes takes a second or two to trigger.

    If it doesn't trigger right away, try switching to another window and then back again. That often triggers it for me.

    I'll talk it over with the other devs and consider adding a menu option.

  • KevinMullinsKevinMullins USMember, Beta ✭✭

    @jstedfast unless I go through the steps above, it doesn't matter how many time Xamarin Studio loses or gains focus or how long I wait... 95% of the time it simply will not read the changes from Xcode.

  • MichaelCozziMichaelCozzi USMember

    I am seeing the exact same issues. These issues have been exacerbated by the upgrade to Xcode 4.6.1. I would also like to point out that the synchronization causes issues with the generation of Stub files.

    Here is my usecase:

    1. Add a view controller to my xamarin project
      1.A. This generates a view controller
      1.B. This generates a xib

    2. I will open up Xcode
      2.A. I can edit the xib and launch the program and the updates will show
      2.B. The header files are not being dynamically generated, they also cannot be manually generated and linked.

    To remedy this I've tried to downgrade to XCode 4.6.0 but this also causes another set of issues (maintaining concurrent XCode installs does not make XCode happy and I am also unsure of how to change which reference to XCode Xamarin is using so I can set it to use the previous version of XCode.

    As far as I am aware this is a brand new bug (I was not having these problems before the update), Thanks,

  • MichaelCozziMichaelCozzi USMember

    Quick Update:

    Downgrading to XCode 4.6.0 helped solve my problem. You can download the appropriate version of XCode here:

    Another issue that I have that deals with XCode simulator launching is also solved by Clicking on my "Device Launcher" iPad Simulator 6.1 iPhone Simulator etc... Drop down and reselecting my device, cleaning the project, then launching.

Sign In or Register to comment.