Forum Xamarin.Forms


Hallo, in this example only the local images are working and the downloaded are not shown. I tried some other examples (webview/image) and got the same result. With the emulator (android browser) i have no problem to find the images.

Could this be because of the trial version?


  • CraigDunnCraigDunn USXamarin Team Xamurai

    The trial version should not affect the code itself.

    I've just re-tested on both an emulator and device - the working with images sample works fine (i'm using the Xamarin Android Player emulator and a Samsung Galaxy Note 3 on wifi). Depending on the network speed the images on the Download tab may take a second to load up, but they definitely appear.

    The only thing I can think to check is : does your Android project definitely have the INTERNET permission ticked in Android Application options?

  • Tom.3717Tom.3717 USMember

    On WorkingWithImages.Android the Required permisson Internet is ticked and I waited over 10 min.
    <uses-permission android:name="android.permission.INTERNET" />
    Are you sure about the trial?

  • CraigDunnCraigDunn USXamarin Team Xamurai

    Well, I never rule out bugs, but a lot of people use the trial and pretty much all the time people are building internet-connected applications, so I always recommend people check configurations and such first. In my case I tested on both the Xamarin Android Player as well as a real device to verify that the code itself wasn't the cause.

    What emulator and/or device are you testing with? Are you able to try another sample that downloads content from the internet, such as the HttpClient demo?

    Also, did you try changing the URLs to some other image location?

  • Tom.3717Tom.3717 USMember

    Ok its not because of the trial. On my tablet everything is working fine.
    I tried a lot of examples and always had the same result.
    I am using the emulator from the Android SDK.

    Like i said the emulator browser can find the picture a simple android app can do it too.
    Thanks for your replay maybe the proxy is doing some crazy stuff.

Sign In or Register to comment.