Forum Libraries, Components, and Plugins

How are new versions supposed to work with the component store?

We are seeing a component version in the store that's over 1 year old, when many versions have been released since then. Are we supposed to go to the vendor for new versions? Isn't this supposed to be seamless inside our Xamarin IDE?

Answers

  • moljacmoljac HRBeta ✭✭✭

    Hi Thomas

    Could you be more specific please? Yes some components are older (even older than 1yr).

    If you observe component store right now there is process of porting all iOS components to Unified API and it is driven by number of downloads. The most cumbersome part of component is to make smart sample which will show most of the features and give users starting point and this takes time. Besides, both iOS and Android are moving targets and Xamarin products, tools and environment need to follow them and when tools and IDE are prepared components can be "produced", so there is delay to be expected.

    Then there is another problem some components are maintained by Xamarin although real code owner is someone else (check SignalR, RX.net - Microsoft). Porting/fixing/updating is not trivial and it takes some time.

    it would help a lot to specify the need for update - the best way is to comment the component on the store and this will trigger at least discussion if not more.

    thanks

    mel

  • ThomasMcKaneThomasMcKane USMember, University

    TeeChart was the current component we had issues with. Here was their blog post showing a new Oct release:

    http://www.steema.com/entry/230/TeeChart_NET_for_Xamarin.iOS_v2014_4.14.10.22_maintenance_release

    The one in the Xamarin store is old and doesn't compile. We've purchased the license and are still trying to get the new version to use.

  • ScottieHacklemanScottieHackleman USUniversity ✭✭

    I am the developer directly working on this project and I wanted to weigh in and at least show what I have tried, the path I have taken, and where it has dead ended. I started by opening up the component store in Xamarin 5.6.2 for Mac by hitting edit components. The store loaded and I clicked on TeeChart Charting Library 13.12.20 by Steema Software.

    I paid the $339, and hit download. I got and error stating that the MD5 checksums were not lining up and the component was listed Red in my project. After rebooting I couldn't make this work in Xamarin. I went to components.xamarin.com/dashboard to find my invoice and hit the "download again" button. This downloaded and I was able to add the .dll to my project.

    I set my using statement then in the first line tried "Steema.TeeChart.TChart chart1; " and it wouldn't build with the error "The type ‘MonoTouch.UiKit.UIView’ is defined in an assembly that is not referenced. Consider adding a reference tot assembly ‘monotouch, Version=0.0.0.0" After researching, it sounds like the dll was compiled using the older MonoTouch instead of the new Xamarin platform.

    So I went to the vendor page, and see the current version is 4.14.10.22. I try to download it, but I need credentials on their site to do so. I look on my invoice, and I have a license number, and a password, but no customer number. I contact their sales staff with a copy of my invoice from the Xamarin. They got back too me and give me the customer number.

    So as of this morning, I logged in and pulled down the newest build directly from Steema, and still getting the same build errors even after deleting my Xamarin dll cache. So I went back to looking and found a project that had a tool to update a dll from a 3rd party vendor. (https://github.com/rolfbjarne/iOSRefUpdater) When I ran it, it said there is nothing to update.

    I am now working directly with support at Steema now to understand why I am still getting an error, and if it something on my end or theirs.

Sign In or Register to comment.