Debuggee returned error code 200.

WesleyTeixeiraWesleyTeixeira ✭✭BRMember ✭✭

Hi everyone

I'm getting this error when I try to debug a Xamarin forms application:

Mono.Debugger.Soft.CommandException: Debuggee returned error code 200. em Mono.Debugger.Soft.VirtualMachine.ErrorHandler(Object sender, ErrorHandlerEventArgs args) em Mono.Debugger.Soft.Connection.SendReceive(CommandSet command_set, Int32 command, PacketWriter packet) em Mono.Debugger.Soft.Connection.Method_GetCustomAttributes(Int64 id, Int64 attr_type_id, Boolean inherit) em Mono.Debugger.Soft.MethodMirror.GetCAttrs(TypeMirror type, Boolean inherit) em Mono.Debugger.Soft.MethodMirror.GetCustomAttributes(TypeMirror attributeType, Boolean inherit) em Mono.Debugging.Soft.SoftDebuggerBacktrace.CreateStackFrame(StackFrame frame, Int32 frameIndex) em Mono.Debugging.Soft.SoftDebuggerBacktrace.GetStackFrames(Int32 firstIndex, Int32 lastIndex) em Mono.Debugging.Client.Backtrace.GetFrame(Int32 n) em Mono.Debugging.Client.Backtrace..ctor(IBacktrace serverBacktrace) em Mono.Debugging.Soft.SoftDebuggerSession.GetThreadBacktrace(ThreadMirror thread) em Mono.Debugging.Soft.SoftDebuggerSession.HandleBreakEventSet(Event[] es, Boolean dequeuing) em Mono.Debugging.Soft.SoftDebuggerSession.HandleEventSet(EventSet es) em Mono.Debugging.Soft.SoftDebuggerSession.EventHandler()

(http://i.imgur.com/9D2Y8h3.png)

The interesting part is that i can debug the App.cs, but as I keep going "inside" the application this error occurs.

Thanks in advance

Posts

  • WesleyTeixeiraWesleyTeixeira ✭✭ BRMember ✭✭

    Update: Debug crashes in App.cs now

  • BrunoPacolaBrunoPacola BRMember

    I have the same problem = /

  • akamudakamud ✭✭ BRUniversity ✭✭

    Same problem here.

  • seansparkmanseansparkman mod USInsider, University, Developer Group Leader mod
    edited October 2014

    I am having this issue as well. It started right after updating today. If I don't set a breakpoint, the application runs without issue.

    Update: I tried switching to beta channel, but there wasn't any change.

  • seansparkmanseansparkman mod USInsider, University, Developer Group Leader mod

    I've tried deleting the SUO file, cleaning the solution, etc.

  • pedrofcjpedrofcj ✭✭ USMember ✭✭

    Same for me

  • CraigDunnCraigDunn Xamurai USXamarin Team Xamurai

    All, I have not seen this error myself, but it would be great if you could all supply more information so we can see if there are any commonalities in your setups. Things like: IDE (are you all using VS?), IDE version, operating system (are you all using Windows?), platform (Android, iOS?), debug target (emulator/API/OS level OR real device)? If Android, what deployment options are set (use shared runtime, fast deployment, linker settings, ABI choices)?

    There is already bug #23830 raised in bugzilla so I would encourage you to keep an eye on that, and add any additional information you have to help the team identify and resolve the issue.

    Thanks!

  • WesleyTeixeiraWesleyTeixeira ✭✭ BRMember ✭✭

    Hi @CraigDunn‌, thanks for the answer.

    I'm using Visual Studio 2013 Ultimate (version 12.0.30723.00 update 3) and Xamarin Studio 5.5.2 build 0 (the error occurs on both)

    Windows 8.1 Enterprise N

    Debbuging an Xamarin Forms app on 3 Android devices: Genymotion Motorola Moto X - 4.4.2 - API 19, Galaxy S4 (GT i9505) running Andoird 4.4.4 with latest CyanogenMod and a Galaxy Tab 3 (GT-P5200) running Android 4.2.2 (no Mod, original Android)

    Application settings: using shared Mono runtime, fast assembly deployment, Linker behavior: don't link, ABI: armeabi, armeabi-v7a, x86.

    If you need more information, just let me know, please :)

  • seansparkmanseansparkman mod USInsider, University, Developer Group Leader mod
    edited October 2014
    • Windows 8.1 Pro
    • VS 2013 12.0.30723 Update 3
    • Parallels 10
    • Microsoft Visual Studio Ultimate 2013
    • Version 12.0.30723.00 Update 3
    • Microsoft .NET Framework
    • Version 4.5.51641
    • Xamarin 3.7.230.0 (e78d10d6993f95fc3ebe791aeb4aacff165bf8bb)
    • Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.
    • Xamarin.Android 4.18.0.39 (0ef616ae42005ece52f6df7aa1e093ceb11998f8)
    • Visual Studio plugin to enable development for Xamarin.Android.
    • Xamarin.iOS 8.4.0.0 (209abebbd8f1a292d042420edb45fa5fbd3f017b)
    • Visual Studio extension to enable development for Xamarin.iOS.

    • OSX 10.9.5

    • Xamarin Studio 5.5.2 (build 3)
    • Xcode 6.1 (6604) Build 6A1052d
    • Xamarin.iOS 8.4.0.15 (Business Edition)
    • Xamarin.Android 4.18.0
  • Luke.7184Luke.7184 USMember
    edited October 2014

    I'm also encountering this issue while attempting to debug a Xamarin iOS project on iPhone 4s and iPhone 5s.

    • Windows 8.1 Pro
    • Microsoft Visual Studio Premium 2013
    • Version 12.0.30723.00 Update 3
    • Xamarin 3.7.230.0 (e78d10d6993f95fc3ebe791aeb4aacff165bf8bb)
    • Xamarin.Android 4.18.0.39 (0ef616ae42005ece52f6df7aa1e093ceb11998f8)
    • Xamarin.iOS 8.4.0.0 (209abebbd8f1a292d042420edb45fa5fbd3f017b)

    • OSX 10.9.4

    • Xamarin Studio 5.5.2 (build 3)
    • Xcode 5.1.1 (5085) Build 5B1008
    • Xamarin.iOS 8.4.0.15 (Enterprise Edition)
    • Xamarin.Android 4.18.0 (Enterprise Edition)
  • EftimescuMirceaEftimescuMircea USMember

    +1!

  • FrancoisMFrancoisM ✭✭ FRUniversity ✭✭

    +1

  • JOAOSerraJOAOSerra ✭✭ PTMember ✭✭

    +1

  • CharlesHoranCharlesHoran ✭✭ USMember ✭✭

    This seems to show up anywhere you either use a Task or async/await.

  • DerrickBrown.9464DerrickBrown.9464 USMember

    Having the same issue in an async/await method

  • SteveMacdonaldSteveMacdonald ✭✭ CAUniversity, Certified XTC Partners ✭✭

    Ditto

  • JacobSteeleJacobSteele ✭✭ USMember ✭✭

    +1

  • prashantvcprashantvc Xamurai USXamarin Team Xamurai

    This bug fix may already be in stable. Has anyone experiencing this issue since the push of Xamarin.Android v4.18.1?

  • RussellCollinghamRussellCollingham ✭✭ GBUniversity ✭✭

    I have latest stable and am still getting the issue.

  • JohnBotibolJohnBotibol ✭✭ GBMember ✭✭

    I have latest stable build (Xamarin 3.7.248.0, Xamarin iOS 8.4.0.0, Xamarin Android 4.18.1..3) and am getting the issue running iOS forms app with a breakpoint set.

  • WesleyTeixeiraWesleyTeixeira ✭✭ BRMember ✭✭

    Xamarin.Android Version: 4.18.1 and still getting this error

  • CharlesHoranCharlesHoran ✭✭ USMember ✭✭

    Prashant,

    Are you saying that Xamarin doesn't know if a bug fix has been released to stable? Or are you saying that you might or might not have fixed it?....I'm confused by a Xamarin employee not knowing what has or has not been fixed in a release.

  • YannROBINYannROBIN ✭✭ FRUniversity ✭✭

    Same here, last stable version, and can't debug

  • JoeModica.7767JoeModica.7767 USMember

    +1

  • BUFFETBUFFET USMember

    Any update ?
    +1

  • CharlesHoranCharlesHoran ✭✭ USMember ✭✭

    To be fair I suspect this is a more of a mono bug than a xamarin one.

  • PaulSavine.4373PaulSavine.4373 USMember

    Same problem here :-(

  • pavanputhrapavanputhra INMember

    Hello Xamarin, following information may help you to reproduce the bug.

    This error will happen when async function is added to few of event handler. Here is one such illustration.

    editView.EditorAction += async (sender, e) =>
    {
    
    };
    

    Even though above handler is empty, error occurs. If I remove async keyword then every thing works fine.

    And to be clear, error isn't due to missing awaitable method inside body, because following code also returns same error.

    editView.EditorAction += async (sender, e) =>
    {
        await SomeFunctionAcync();
    };
    

    By the way above error is Runtime error. Till the above event is not fired app will run properly.

    Hope this will help to fix the bug.

  • CraigDunnCraigDunn Xamurai USXamarin Team Xamurai

    FYI: engineering have updated the bug report, release should be this month (November).

  • RezaMousaviRezaMousavi GBMember

    I too have this issue.

    Xamarin.Android Version: 4.18.1.

    As with the above posts, my class uses Task await async.

    It runs absolutely fine on Xamarin Studio.

    Strangely, I have two apps using the same class, yet one of them is absolutely fine and the other isn't. It seems like a combination of things is causing it. I have tried reproducing in a standalone application, but I have failed to do so successfully - sorry.

    [DebuggerStepThrough] does not help.

    Hope that helps.

  • RezaMousaviRezaMousavi GBMember

    Great! Thanks Craig!

    P.S. Sorry hadn't refreshed the page before my post.

  • aaragaoaaragao BRMember

    I got the same issue, the update that includes this bug fix has already been released?

  • GeorgeCookGeorgeCook ✭✭✭ PEUniversity ✭✭✭

    I get this constnatly now, on latest alpha and stable. Only on one project.

    I can't debug it with breakpoints at all anymore - they just go crazy and are all over the place. What's shown in the IDE is clearly not what's being executed.

  • SmathsSmaths ✭✭ USMember ✭✭

    I'm also getting this error extremely frequently. This in addition to breakpoints not working on Visual Studio is making development with Xamarin extremely memorable. Ugh, I wish simple things like debugging worked competently because xamarin is already buggy/painful enough––at least let me understand why things are not working!

  • JBUJBU USMember

    Add me to the list of people having trouble with this. I must say the disconnect between bugs identified and bugs fixed in this forum is a little disconcerting.

  • JBUJBU USMember

    Update: wound was partially self-inflicted, in that I did not have async on my event handler.

  • MrAskMrAsk USMember

    Hi I am currently experiencing the Mono.Debugger.Soft.CommandException: Debuggee returned error code 200. I am using VS2017 and my jdk is 1.8 and I am using a real physical device to debug. This error only occurs when I add breakpoints to the solution. If i remove the break points and I deploy there will be no exception but all I see is just a white screen with nothing on it. Any idea how to resolve this?

  • MelbourneDeveloperMelbourneDeveloper ✭✭✭ AUMember ✭✭✭

    I'm getting this now...

  • HaggaiShapiraHaggaiShapira ✭✭ ILMember ✭✭

    I'm getting this error as well. Please note me when workaround is found

  • WinSomeLoseSomeWinSomeLoseSome ✭✭ USMember ✭✭
    edited October 2017

    MrAsk, I'm seeing the same behavior you are. Crash if breakpoint set, blank screen after splash screen if I remove the breakpoints. I'm guessing there are some issues like this that don't happen that often, and aren't easy to isolate given the large numbers of variables involved.

    Here are some debugging steps I use in case it helps:

    0) Exit VS, delete all obj and bin folders, restart VS, reload solution in VS, open project, clean, rebuild all.
    1) try to get back to the last working state and add things incrementally (Assuming you have backups/checked in code you can revert back to).
    2) Debug.WriteLine statements to dump stack trace since breakpoints aren't working. Didn't help in this case, at least not yet. Added to MainActivity (after removing splashActivity) and to App.xaml.cs and to main page of my app.
    3) Start removing elements from main page all the way back to no code behind and no xaml.
    4) Make sure, double sure, that all resources are added to the project and spelled correctly (must match case!)
    5) Update packages (note: on Mac, Update All Packages has been helpful in many cases. Not so in this case with VS 2017 enterprise version.

    Those are the basics, but there is another layer of tricks that aren't as easy to recall off the top.

    Edit: reverting my code back has it working again, or at least not seeing the above issues any longer. Now for the incremental changes...

Sign In or Register to comment.