Forum Visual Studio

IOS AppStore build on Visual Studio errors in Application Loader

GuidoKerstenGuidoKersten NLUniversity ✭✭
edited October 2014 in Visual Studio

Hi All,

At the moment I ran into some problems when I am trying to build my app to publish for the App Store in Visual Studio.

I tried to follow this guide, which almost helped me through the complete process, but I found it did no tell me anything about compiling the app in Visual Studio for AppStore release.

So I used some other guides and finally I managed to successfully build the app and I got a .app package to upload to iTunes Connect. I zipped this .app file and launched Application Loader (3.0), I choose ‚Deliver your app’ and press ‚choose’ and select the zip file. Then I get the error messages, as shown in this

After seeing these errors I checked my info.plist again, but the keys are there. I tried searching for any one who was facing this same problem, but could not find anything helpfull. My first thought was that it had something to do with the problems I had when opening the info.plist, but after an update I just did, this problem was solved.

As a work-around I tried to do this App Store build process in Xamarin Studio, but then I faced problems when simply trying to build the app in Debug or Release as other faced here

So is there anybody who has faced this same problem or anyone who can help me get any further?

I discoverd that I could look at the contents of the .app package. There I found the problem: All files are 0 bytes, but it contains all the files that should be there. Am I missing something in the build process? I have the right Provisioning Profile and certificate, then select AppStore and iPhone in the configuration and right-click > Rebuild on my solution. Then I get the .app in my bin/iPhone/AppStore folder inside my iOS project.


  • GuidoKerstenGuidoKersten NLUniversity ✭✭
    edited October 2014

    After much searching I finally found out that the .app (with content) is not put in the /bin/iPhone/AppStore folder, but in the Xamarin cache on the Mac Buildserver, as shown here.

Sign In or Register to comment.