Forum Xamarin.Android

Mono for Android 4.2.8 - Problem deploying

MatteoPolitoMatteoPolito ITMember ✭✭
edited October 2012 in Xamarin.Android


after updating to the latest version of Mono for Android I can't deply application on emulator or device.
This is the error message:

Deployment failed. Internal error

To deploy and build my application I've to install Mono for Android 4.2.6.
How to solve this issue? I'm using monodevelop on Mac.


  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    Can you provide Diagnostic build output?

    Within Visual Studio:

    1. Click Tool > Options...
    2. In the left-hand tree view, select Projects and Solutions > Build and Run
    3. In the right-hand panel, set the MSBuild build output verbosity dropdown to Diagnostic
    4. Click OK
    5. Clean and rebuild your package.

    Within MonoDevelop/OS X:

    1. Click MonoDevelop > Preferences...
    2. In the left-hand tree view, select Preferences > Build
    3. In the right-hand panel, set the Log verbosity drop-down to Diagnostic
    4. Click OK
    5. Restart MonoDevelop
    6. Clean and rebuild your package.
  • MatteoPolitoMatteoPolito ITMember ✭✭

    Ok. Done. I've sent you an email. Thanks

  • I encountered two problems in win 8 pc after upgrading to 4.2.8, I lost my activation which i corrected by downloading the license file from Xamarin site and copying to my Users Directory as per the instructions mentioned during download.

    Another problem i encountered was that I was not able to deploy a HelloWorld apk (Usually all my packages have two parts) (May not be related to 4.2.8) because the Package Name did not have a .[dot]. Once I corrected the package name to Mvp.HelloWorld i was able to deploy.

  • StephenHauckStephenHauck USMember ✭✭✭

    I just tried to use an old Android app and got the same error "Deployment failed. Internal error"

    I changed the build log settings like above but did not get any error reports.

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    @StephenHauck: Unfortunately, not all useful log information is generated by MSBuild. There are two other places to look:

    1. The Android Debug Log can contain useful information.
    2. The Device Deployment Logs can also contain useful information.

    I would suggest checking logcat and the Device Deployment logs to see if anything looks relevant.

  • TomOpgenorthTomOpgenorth CAXamarin Team Xamurai

    @StephenHauck - trying turning off Linking when you compile your project in Release mode, and see if that fixes the problem.

  • StephenHauckStephenHauck USMember ✭✭✭

    OK, I got the Android Log to show...

    11-03 16:04:14.245 D/AndroidRuntime( 388): >>>>>> AndroidRuntime START <<<<<<
    11-03 16:04:14.245 D/AndroidRuntime( 388): CheckJNI is ON
    11-03 16:04:14.864 D/AndroidRuntime( 388): Calling main entry
    11-03 16:04:14.904 D/AndroidRuntime( 388): Shutting down VM
    11-03 16:04:14.925 D/dalvikvm( 388): GC_CONCURRENT freed 99K, 83% free 361K/2048K, paused 1ms+0ms
    11-03 16:04:14.925 D/jdwp ( 388): adbd disconnected
    11-03 16:04:14.944 I/AndroidRuntime( 388): NOTE: attach of thread 'Binder Thread #3' failed

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    @StephenHauck: Please try to redeploy your app. The logcat output you provided doesn't contain any output from a Mono for Android process; there will be a message containing __mono_init__ from Mono for Android processes.

  • StephenHauckStephenHauck USMember ✭✭✭

    I started a new solution and copied code to the new solution and everything worked fine, I even used the same emulator image.

    I have no idea what went wrong but as I get more familiar with the product I will definitely come back to this project and try to figure out what went wrong.

  • khcamkhcam KHMember

    I used xamarin to develop android app. when I try to run app it load bellow message:

    Deployment failed because of an internal error: Unexpected install output: pkg: /data/local/tmp/KhmerFoodGuide.KhmerFoodGuide-Signed.apk

    Deployment failed. Internal error.

    please help

    thanks in advance

Sign In or Register to comment.