Latest build not copying to simulator?

I seem to be having an issue where when I do a F5 from VS to build and debug on an iOS simulator sometimes the build is not copied over to the simulator and an old build is ran instead. Breakpoints fire in incorrect spots and locals display an error saying that the identifier cannot be found.

Seems to happen at random ever since the last release.

Anybody else seeing this?


  • KarinKarin USMember

    Same problem here. The build appears to deploy to the iOS simulator initially but never again. I've tried deleting the application and restarting all the applications and Host. I did notice the "Deploy" option in the Configuration Manger is not only unchecked in the iOS project but is disabled.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai


    Yes, the Deploy box is unchecked and disabled, but behind the scenes Deploy is set. There is a bug report requesting that a checkmark be displayed to indicate that it is indeed set, even though disabled (I.E. you can't unset it). It was disabled and permanently set to avoid some issues that were occurring with it not being checked.

    That said, currently you can not deploy Xamarin iOS projects to the 7.x simulators. Please see:

    At the bottom:

    "Known Issues
    Using the iOS 7.0 and 7.1 simulators included with Xcode 6 is not currently supported. The issue is being tracked in bug 22750 and will be fixed in the 8.2.0 release."

    Xamarin.iOS 8.2 is now available as a Beta release in the Beta update channel.

    If that is not the issue, then try cleaning the build cache on the Mac. You can do this by deleting the contents of the builds, uploads, and zips folders in ~/Library/Caches/Xamarin/mtbs/
    (Absolute path: /Users//Library/Caches/Xamarin/mtbs/)

    I hope this helps!


  • KarinKarin USMember

    Does not work with iOS 8 either. Clearing cache does not work. This is totally broken for me and I've stopped using Visual Studio and have been forced to the Mac. I've tried latest, Beta and Alpha channels with no success.

Sign In or Register to comment.