Forum Visual Studio

iOS Project is Unsupported

TeoTeo DKMember ✭✭

As of today at noon, my iOS project in a Xamarin Forms shared library project, Visual Studio 2013 Update 3 stopped working, with this error.

This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them.
For more information on enabling these project types or otherwise migrating your assets, please see the details in the "Migration Report" displayed after clicking OK.

The weird thing is that I did not manually update anything, and things were working this morning. I restarted Visual Studio, and then nothing works anymore.


  • DavidStetzDavidStetz USMember

    I am having this issue as well, I am using the latest in the beta channel. Xamarin.iOS on windows and Xamarin.iOS on the Mac. Are these the same version you are using as well. I have noticed that it stops working after it updates the SDK info from the Mac.

  • TeoTeo DKMember ✭✭
    edited September 2014

    A little bit more info. When I'm trying to create a new project, I get this error:

    Microsoft Visual Studio
    A problem was encountered creating the sub project 'TestXamarinCrash.iOS'. The project file '..\Temp\vck5q5ob.32n\Temp\TestXamarinCrash.iOS.csproj' cannot be opened.

    There is a missing project subtype.
    Subtype: '{6BC8ED88-2882-458C-8E55-DFD12B67127B}' is unsupported by this installation.

    Then if I try to go to Tool > Options > Xamarin, if I open the Xamarin.iOS page, there are no options, just an error message that no options are there.

    After a bit more fiddling with it, I finally re-installed Xamarin, and things seem to work.

  • fllukeflluke USMember

    I believe that this is the same problem I am having. iOS project gives me an unsupported error after I updated to the latest version of the software and the SDK "synced". Hope it get's fixed soon!

  • RafaelCrdenasOrtegaRafaelCrdenasOrtega MXUniversity ✭✭

    I have the same problem, the IOS project appears as incompatible, I have to present an app on monday, I'll copy the project to my MAC and then use Xamarin Studio to deploy it, while waiting for a fix

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    From the reports so far, it sounds like performing an SDK sync somehow causes this problem to appear. Constantin's solution of uninstalling [1] and reinstalling XamarinVS 3.6.245, and then ignoring the SDK sync update message bubble might be a good temporary workaround. I'll continue to investigate. Hopefully the developers will be able to solve the problem first thing on Monday.

    [1] To make sure the uninstall works completely, you can also manually delete the reference assemblies folders if they still exist:

    C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoTouch


    C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\Xamarin.iOS


    If reinstalling the current version doesn't work, you can try downgrading to one of the previous pairs of stable versions:

    Early September versions

    Windows: Xamarin 3.5.58
    Mac: Xamarin.iOS

    August versions

    Windows: Xamarin 3.3.47
    Mac: Xamarin.iOS

    Download links

    You can find the download links for either of these pairs of versions on

  • imkowJackimkowJack CNMember ✭✭

    @BrendanZagaeski‌ the workaround doesn't work, only first time running VS after done that works.

    If close VS and restart VS again, the problem appears again.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited September 2014

    I have compiled together all of the information I've found so far about this problem from the forums, emails, and Bugzilla, and filed a critical bug here:

    I have also directly notified the developer and release coordination teams about the problem. There should be an update on this bug during the day on Monday, if not sooner.

    Check registry for Visual Studio PendingDeletions

    Based on the symptoms so far, it's possible that performing an even more thorough uninstall might help get things working. There might be some file or preference that's causing Visual Studio to uninstall or unregister the Xamarin.iOS extension. One possibility is that there might be some Xamarin entries under the following registry key:


    If you see this key in regedit, you can delete any entries that look like they might be related to Xamarin. For example, here's one that used to cause trouble in older versions of Xamarin:


    After deleting the registry key, you might need to rerun the Xamarin installer once more:
    Xamarin 3.6.245

    Thorough uninstall

    In addition to checking for the PendingDeletions key, you can try a few other steps, like manually deleting the Xamarin Visual Studio extensions folder after uninstalling Xamarin via the Programs and Features Control Panel.

    See the full set of steps here:

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited September 2014

    Just to throw out one more possibility, the first error during the Xamarin.iOS extension initialization [1] sounds like it could be caused by a problem with the Visual Studio installation. Xamarin 3.6 might be using some APIs during initialization that Xamarin 3.5 did not use, and the Visual Studio installation might be missing the required "Microsoft.VisualStudio.Debugger.Interop.Internal" assembly (or one of its dependencies). So there's at least a small chance that running a repair on the Visual Studio installation might solve the problem.

    [1] From the stack traces in the devenv*.log files:

    System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.VisualStudio.Debugger.Interop.Internal, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.

  • JohnBotibolJohnBotibol GBMember ✭✭

    Well now, I have done a thorough uninstall and clean up, re-installed from the subscription link and so far so good ... except that the "current" release installed from my subscription is 3.5.58 which would infer that 3.6 has already been withdrawn from stable releases. However on opening a project in VS I am prompted to update Xamarin iOS (yup, to 3.6.245). I guess the best answer to that is "no thanks" :-). Keen to hear of a fix on Monday because 3.6 apparently has an Android related fix I am awaiting.

  • Same thing here, but on Visual Studio 2010. It previously worked great using 3.5.58, but after updating to 3.6.245, everything works on the first launch but after a SDK sync with the build host, the plugin cannot be loaded at all.
    The thing is that I need the 3.6.XXX version since I need iOS 8 support, so I cannot ignore that update.

    Worth noting is that I had exactly the same problems in the beta channel last week.

  • If I run Visual Studio with logging as described at ,

    I find the following error in my ActivityLog.xml:

    <entry> <record>260</record> <time>2014/09/22 08:39:25.281</time> <type>Error</type> <source>VisualStudio</source> <description>SetSite failed for package [Xamarin.VisualStudio.IOS.MonoTouchPackage, Xamarin.VisualStudio.IOS, Version=, Culture=neutral, PublicKeyToken=0738eb9f132ed756]</description> <guid>{77875FA9-01E7-4FEA-8E77-DFE942355CA1}</guid> <hr>80131500</hr> <errorinfo>Activation error occured while trying to get instance of type IBuildHost, key ""</errorinfo> </entry>

  • FrankBuckleyFrankBuckley GBUniversity ✭✭

    I am seeing this problem despite complete uninstall and new install (3.6.245).

    I find that running VS as Administrator, then opening a solution with a single IOS project in it almost always (but not always) fixes the problem and I can then go ahead and load our solution with multiple IOS projects successfully.

  • I just did a thorough uninstall and a new installation, and the error is the same as before. Running as an admin does not make any difference at all.

    Maybe a slight difference after reinstall (I am not sure if this was the same before): when I go to Tools -> Options and click on Xamarin, I get a popup dialog saying "One or more errors occured. See More Details for additional info". But there is no More Details button. Also, the title is "Error populating device list".

    I can then view my Android Settings, but if I click iOS Settings, I only see the text "An error occured loading this property page".

  • DavidStetzDavidStetz USMember
    edited September 2014

    Doing the cleanup as Brendan stated has not worked for me.

  • jdevxjdevx USMember

    I was able to get around this by closing and restarting the build host on the mac first and then opening Visual Studio and the solution. The bug link listed in this chain also has comments where that worked so it's something to try if you're using a mac build host.

  • DavidStetzDavidStetz USMember
    edited September 2014

    I have also tried those and they have not worked. The only thing that resets it is uninstalling and re-installing. But it only works temporarily and usually breaks shortly after connecting to the mac host.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited September 2014

    We have a candidate hotfix build in progress. We should have a link ready soon.

  • I received a link to a hotfix candidate (3.6.249) tonight (02.25 Swedish time) and just tested it and it works like a charm.

    Thanks a lot. When You have got used to doing your iOS development inside Visual Studio (with Resharper) it is quite rough to go back to Xamarin Studio on the Mac.

  • How did you receive the hotfix candidate? I'm having the same issues. Can't find a download link.

  • TeoTeo DKMember ✭✭

    When I logged in this morning, I got a notification that an iOS update is available. Maybe that is it?

  • AndreasPaulssonAndreasPaulsson SEMember ✭✭
    edited September 2014

    @RolandvanderPlas, I received an email from Xamarin support since they have been monitoring this thread. I do not want to disclose the download link since it was in an email and it was a hotfix candidate, not a proper release.

    I guess that there will be a proper release "soon".

  • Hi, I am having this issue to. Can I get the link for downloading the hotfix please?

  • @AndreasPaulsson, Ok, thanks. Guess I'll have to wait a bit and focus / debug / test on the Android app. I'm in no hurry ;)

  • MarianGrzesikMarianGrzesik DEUniversity ✭✭

    Hi, now I have the Problem too. Is there any HotFix?

  • CarelLotzCarelLotz ZAMember ✭✭

    Same issues here. Patiently awaiting the hotfix

  • FrankBuckleyFrankBuckley GBUniversity ✭✭

    Is this problem also present in 3.7.126?

  • RafaelCrdenasOrtegaRafaelCrdenasOrtega MXUniversity ✭✭

    I installed 3.7.126 and IOS Project is still incompatible and now can't load Android Project, I'll wait for the hotfix.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited September 2014

    I've requested that the hotfix candidate build be published to the stable channel. With a little luck, it will be available later today.

    If you'd like to try it before then, you can download it from here:
    (EDIT: The hotfix build is now available on the stable updater channel, so I've removed the link from this post.)

    To avoid any confusion, I'll come back and remove this link once the hotfix is available in the stable channel.

  • FrankBuckleyFrankBuckley GBUniversity ✭✭

    @BrendanZagaeski - thank you. Is a fix for this issue also planned for the 3.7.x release in the beta channel?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    I'll make sure they're planning to apply the fix to that branch too. I suspect it'll be included in the next beta channel release.

  • aro2468aro2468 USMember

    Is the hotfix in the beta channel? I have the latest code in the beta channel as of 9/24 and it's the same problem w'here it says "This project is incompatible...."

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Not yet. It will most likely be included in the next beta channel release (it has been applied to the beta channel development branch).

  • YanachagaYanachaga USMember ✭✭

    Thanks, Brendan I follow your instructions to downgrade to

    August version
    Windows: Xamarin 3.3.47
    Mac: Xamarin.iOS
    XCode 5.1

    Now everything is working.

  • PhongLe.1026PhongLe.1026 USMember
    edited October 2014

    Haha. Need to install Xamarin bonjour service and run it. Then, everything is ok
    Control panel -> Uninstall a program -> Xamarin -> Change -> Enable bonjour responder

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    At all Readers of this thread:
    If have done a test of the newsest pre-Alpha-version of the Xamarin-VS-Integration software yesterday.
    Thereby I also have tried to solve a problem with the WP-Emulator (port already is in use) and therefore have stopped the "Xamarin Bonjour-Service" in the task-manager (to check, if it causes the problem, was what not the case).
    After doing that (close service), I had no problems to further work with VS...
    Today I had a VS error-message by open the solution-file, that the iOS-project is not compatible with VS (2013).
    First, I feared, that something (new update) has destroyed my iOS-project, then I have found the posting from Phong Le here (Bonjour Service).
    I then have started the Bonjour Service again in the task-manager and now further be able to open the iOS-project.
    Thanks @PhongLe.1026 for your posting here...
    Until now, I thought, that the "Bonjour-Service" only does check and show updates to the Xamarin-VS-Integration- Software
    I further thought, that the Bonjour-Service is loaded automatically (with the start of VS).
    Now, I know:

    • That - if the "Bonjour Service" is not loaded, the iOS-project cannot be loaded (with an absolute misleading error-message)
    • That - the "Bonjour Service" is not loaded automatically, If you have stopped it

    So... If you have this error-message, first check, in Task-Manager if the Bonjour-Service run's :sunglasses:

  • LeslieCorreaLeslieCorrea USMember ✭✭

    For Visual Studio 2015 on windows 10 if iOS project is not loading
    Try deleting ComponentModelCache

    Default location is C:\Users\username\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache

    First close Visual Studio
    Then delete ComponentModelCache
    Then start Visual Studio

    It will load iOS project.

  • karan78karan78 INMember ✭✭

    Go to ‘Uninstall Or Change a Program Window’ {“Control Panel\Programs\Programs and Features”}, Find ‘Visual Studio 2015 Tools for Xamarin’ And Repair It.

    It Solved My Problem :smile:

Sign In or Register to comment.