iOS 8 issues

ErnestJErnestJ AUMember ✭✭

Hi,

Trying to test our app with iOS8 before submitting update to Apple.

Installed XCode 6, also downloaded iOS 7.1 SDK as we still want to support it. Switched Xamarin Studio to alpha channel so we can get iOS 8.0.

Have 2 issues:

  1. Crashing in Monotouch Dialog ELement.cs method called "InsertVisual" with SIGBART error, in line:
    root.TableView.InsertRows (paths, anim);
    This method is called when adding element to a section and it has a parent element.

  2. Not being able to run 7.1 at all, Xamarin Studio simply shows error: "Application Terminated"

Is anyone successfully using iOS 8 with Monotouch Dialog? I'm not sure if the issue is in Monotouch Dialog or alpha build library itself.

Posts

  • AlexWhiteAlexWhite GBMember ✭✭✭

    I hit a load of problems with the betas of IOS8 and MT.D lots of crashes in my apps, but I can confirm as of an hour ago the release build of IOS8 does not have the issues anymore, Action Sheets also work again (they were displayed at the top of the screen, they are now in the right place again).

    Upgrade to the release versions of everything and it should work.

    All The Best

    alex

  • ErnestJErnestJ AUMember ✭✭

    Thank you, which version it shows in your Stable channel for you?
    It shows 7.4.0.108 for me which is not working properly for me.

  • AlexWhiteAlexWhite GBMember ✭✭✭

    Sorry I should have mentioned that I am using the stable channel and not the latest build (that version killed push notifications completely for me, so rolled back one version), Both my main commercial apps are fully running now (both use MT.D extensively)

    === Xamarin Studio ===

    Version 5.2.1 (build 1)
    Installation UUID: 0feb37e3-90ab-4558-bd30-95e0bd4773ba
    Runtime:
    Mono 3.8.0 ((no/45d0ba1)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 308000009
    

    === Xamarin.Android ===

    Version: 4.16.0 (Starter Edition)
    Android SDK: /Users/alexwhite/Library/Developer/Xamarin/android-sdk-mac_x86
    Supported Android versions:
    2.1 (API level 7)
    2.2 (API level 8)
    2.3 (API level 10)
    3.1 (API level 12)
    4.0 (API level 14)
    4.0.3 (API level 15)
    4.4 (API level 19)
    Java SDK: /usr
    java version "1.6.0_65"
    Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
    Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

    === Apple Developer Tools ===

    Xcode 6.0 (6299)
    Build 6A313

    === Xamarin.Mac ===

    Version:

    === Xamarin.iOS ===

    Version: 7.4.0.108 (Indie Edition)
    Hash: 77efa3f
    Branch:
    Build date: 2014-08-26 07:59:55-0400

    === Build Information ===

    Release ID: 502010001
    Git revision: d06832ce9807d6be24aca225457e8b37c7669f6f
    Build date: 2014-08-07 12:10:47-04
    Xamarin addins: 1de032531be4cecf2f39dbee3b87aac78204058c

    === Operating System ===

    Mac OS X 10.9.4
    Darwin alexs-MacBook-Pro-1865.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun 3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64

  • ErnestJErnestJ AUMember ✭✭

    Interesting, if I try to run iOS 8 simulator with same stable build as yours, then it doesn't even run and shows warning in Application Output:

    warning MT1201: Could not load the simulator: dlopen(/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/Library/PrivateFrameworks/DVTiPhoneSimulatorRemoteClient.framework/Versions/A/DVTiPhoneSimulatorRemoteClient, 1): image not found

    If I switch to alpha channel then it runs simulator, but it crashes as per my first post.

  • AlexWhiteAlexWhite GBMember ✭✭✭

    This is what I did this morning.

    Upgraded my iPad to IOS8
    Downloaded Xcode6
    Installed Xcode6

    Nothing worked until I rebooted my mac, I was getting a ton of errors, the right simulators were not listed in XS.

    After reboot everything has started to work correctly to the devices, but I do get the same error as you running the simulators.

    Try to build to a real device to see if that works.

  • ErnestJErnestJ AUMember ✭✭

    Some more info:
    I can debug on my iPhone which has 7.1 without issues. If I run in iPhone Simulator iOS 8, then app will crash in MT.D.

    If I switch from alpha channel to stable channel I can't run in it simulator 8.0 at all, which makes sense as stable version is 7.4 and 8.0 support is only from 7.9

  • ErnestJErnestJ AUMember ✭✭

    Thank you, I haven't upgraded my iPhone yet, but if you get same errors in simulator it means I'm not alone.
    I guess as soon as Xamarin releases stable version of 7.9 it should be all good (hopefully).

    Thanks again for your help!

  • VictorHGarciaVictorHGarcia USUniversity ✭✭

    I'm having the same issue here:

    Installed XCode 6 GM and all SDK required.

    warning MT1201: Could not load the simulator: dlopen(/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/Library/PrivateFrameworks/DVTiPhoneSimulatorRemoteClient.framework/Versions/A/DVTiPhoneSimulatorRemoteClient, 1): image not found

    Is there any setting we need to change on Xamarin Studio to make it work?

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    @VictorHugoGarcia.4087‌: you need Xamarin.iOS from the alpha channel, the version in the stable channel right now (7.4) does not support Xcode 6.

  • VictorHGarciaVictorHGarcia USUniversity ✭✭
    edited September 2014

    Thanks @RolfBjarneKvinge‌ I'll download it right now and start testing... I'll post my results here. thanks.

  • VictorHGarciaVictorHGarcia USUniversity ✭✭

    Hello @RolfBjarneKvinge‌ It worked fine. But however I cannot see the simulators of iPhone 6 and 6 Plus, I guess you are working hard at that right now.

    Let us know when the update be ready to grab it and start testing on those devices.

    Thanks in advance.

  • AlexWhiteAlexWhite GBMember ✭✭✭

    Hi Rolf,

    Does that alpha have the push notification issue (APS)?, I don't want to change from what I have until there is a build with the fix in it.

    All The Best

    alex

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    @AlexWhite: which APS issue?

  • AlexWhiteAlexWhite GBMember ✭✭✭

    The one where you get the following error

    "no valid 'aps-environment' entitlement string found for application"

    the latest release version has the issue, I rolled back to the previous released version and the problem went away, this issue completely stops APS working.

    http://forums.xamarin.com/discussion/22502/xamarin-studio-5-3-push-notification-error

    All The Best

    alex

  • BenBishopBenBishop USBeta ✭✭

    I updated my Xcode to version 6 this morning and also updated Xamarin Studio to the Alpha channel. I tried running my app in debug mode on the 7.1 simulator. The simulator launched at first, but the app then crashed with no traces to the console. I then tried running it again and then I got a system file system prompt from XS asking me to locate the simulator.

    I can run my project on my device, but not on any of the simulators.

    Any insights would be greatly appreciated!!

  • ErnestJErnestJ AUMember ✭✭

    BenBishop, I've exactly same issues:

    • Simulator 7.1 crashing straight after launch
    • Simulator 8.0 launching, but MT.D is broken

    The only way to test now is on a device which is painful. I guess best is to rollback everything to previous XCode until stuff is sorted out.

  • ErnestJErnestJ AUMember ✭✭

    New version available in Beta channel, unfortunately issues mentioned in this thread are not fixed.

  • I had a crash when using MT.D in ViewWillAppear. Specifically, I was setting Root if the viewController was MovingToParent. Moving this code to ViewDidAppear "fixed" the issue.

    I'm also having a bunch of layout problems when switching to the landscape orientation. It seems the way the screen bounds work has also changed.

  • EricGreenEricGreen USMember

    I am having the same issues with the Simulator as Paul and Ben. Running version 8.0.0.9.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Simulator 7.1 crashing straight after launch

    Unfortunately, Xcode 6 introduced some complications for Xamarin in how the simulator launch works. The Xamarin developers had two options for how to get things working quickly:

    a. Allow the use of SceneKit in the iOS 8 simulator.

    or

    b. Allow the iOS 7 simulators to work.

    At present, Xamarin.iOS is using option (a), so it will not be possible to use iOS 7 simulators with Xcode 6 on Xamarin.iOS 8.0. There are plans for a larger rewrite of the simulator launch code to get both (a) and (b) working, but that functionality will not be available in the initial stable releases of Xamarin.iOS 8.0.

  • BenBishopBenBishop USBeta ✭✭

    HI Brendan,
    I definitely appreciate the insight. It's a bummer that the iOS7 simulators won't be working anytime soon, but at least I can still use my device for that testing. I'll try running the iOS8 simulator and let you guys know if I run into anymore issues.

    Thanks again,
    Ben

  • EricGreenEricGreen USMember
    edited September 2014

    Hey Brendan, Thanks for giving the update. Is there any estimated time as to when the iOS7 simulator will be supported again? It makes it quite more cumbersome to test against iOS8 and iOS7 without the simulator.

    Thanks!

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    You can try enabling the linker for simulator builds, this may or may make the 7.0 simulators work.

    It will however slow down your builds, so you might want to only enable it if you're specifically testing iOS 7.0.

  • RKDF250RKDF250 USMember

    Every time I try and debug my app on the IOS8 simulator the app starts then I get the "Choose Application" window asking me where the iPhone simulator is. The simulator and program actually open behind this popup window.
    Any suggestion on how to prevent this from happening?
    I have the latest Xamarin Alpha Release and Xcode 6. I can still debug the app but this popup is really annoying.

  • RKDF250RKDF250 USMember

    Here is a screenshot and the error that displays after I cancel it....
    2014-09-11 11:28:37.803 PMSOE[1988:78483] MonoTouch: Socket error while connecting to MonoDevelop on 127.0.0.1:10000: Connection refused

  • BenBishopBenBishop USBeta ✭✭

    I'm also running into what @RKDF250‌ is encountering. I was just assuming it would get cleaned up in the next release.

  • EricGreenEricGreen USMember

    @RKDF250‌ and @BenBishop‌ , I had the same issue. I selected Xcode as the application when it came up and then I stopped getting the prompt.

  • RKDF250RKDF250 USMember

    Thanks @EricGreen‌ it is working great now. All I did was select Xcode as the app.

  • KobiShashaKobiShasha ILMember
    edited September 2014

    @RolfBjarneKvinge‌

    The linker made the iOS7 simulator run, but it has a problem (well, at least one I saw) - the keyboard does not show when pressing a text view.
    Any idea?
    And are there any other known problems with it?
    Thanks!

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    @KobiShasha: enabling the linker can have other consequences (it will remove unused code, but in certain cases it's hard to determine if code is actually used or not). You can read more about it here: http://developer.xamarin.com/guides/ios/advanced_topics/linker/

    Have in mind that the linker is enabled by default for device builds, so if you've already tried building for device and it works, it should also work in the simulator with the same linker options.

  • KobiShashaKobiShasha ILMember

    @RolfBjarneKvinge‌
    Thanks!
    Strange, on real devices the linker is on, and the keyboard does show.
    On simulator, when I turn it on, the keyboard doesn't show.

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    @KobiShasha: you're testing on both an iOS 8 device and iOS 8 simulator, right? If so, you might want to file a bug (http://bugzilla.xamarin.com) and attach your project so that we can have a look at it.

  • KobiShashaKobiShasha ILMember

    @RolfBjarneKvinge‌
    I'm using the iOS7.1 simulator. On the iOS8 simulator, as well as on devices, the keyboard does show.
    I can't post my project as it's of a commercial company, but I'll see if I can create a new project and isolate the problem to it.

  • SebastianSeidel.9226SebastianSeidel.9226 DEInsider, University ✭✭✭✭

    I can confirm that enabling the linker on debug builds with iOS 7.1 simulator the app starts and do not crash right after the launch-screen.

  • SmartSmart TWMember

    I'm just stuck.
    My Xamarin Studio is v5.4.
    I want test Google AdMob on my app. But AdMob component can not run on iOS 8.
    Then Xamarin Studio can not launch iOS 7.1 or 7 simulator for testing AdMob.

    Do Xamarin team have plan to fix any one issue above?

  • rmaciasrmacias USBeta, University ✭✭✭✭✭

    @KobiShasha‌ , in reference to the keyboard not showing up, the Simulators work differently for XCode 6. The Keyboard will not show up in the simulator unless you do one of two things:

    1. From the Simulator menu, go to Hardware->Keyboard->Toggle Software Keyboard
    2. From the Simulator menu, go to Hardware->Keyboard and then uncheck "Connect Hardware Keyboard".

    If you do #2, the keyboard will pop up when you gain focus for a text entry field, but you will not be able to type anything using your computer keyboard, only the software keyboard. What I do is keep "Connect Hardware Keyboard" checked, and just select "Toggle Software Keyboard" when I want to see what it looks like with the keyboard toggled. Kind of dumb the way Apple changed it, but that's the way it works now.

  • OZGURAKSUOZGURAKSU TRMember

    @Smart, I don't use AdMob but I was curious to see if Google indeed didn't support iOS8. But in fact, as of Sept. 18th, AdMob has a release that supports iOS8 (https://developers.google.com/mobile-ads-sdk/docs/admob/ios/rel-notes). You could upgrade your component by binding the new version. You probably should use this version if you want to support newer devices anyway.

  • SmartSmart TWMember

    @OZGURAKSU‌ , thanks.
    I did see the warning message, which Google didn't support iOS 8.
    But lately, AdMob can run on my iOS 8 simulator and device.
    And Xamarin Studio iOS can not run iOS 7 / 7.1 simulator is still a really problem.

  • OZGURAKSUOZGURAKSU TRMember

    @Smart yeah I know. That is why I keep my devices on iOS7.1 for now just to be able to test on 7. I hope they fix this soon.

  • IanVinkIanVink CAInsider, University ✭✭✭

    If it helps, the Simulator on iOS 7 crashes for me too. Setting the Linker does not help though in my cases.

Sign In or Register to comment.