Forum Xamarin.Forms

Anyone install VS 2013 Update 3?

EricGroverEricGrover USMember ✭✭

Are there any known issues with update 3? Thought I would ask before I apply it.

Best Answer

Answers

  • RSHRSH USUniversity ✭✭

    I have it running, no issues at all!

  • BoscoBosco USUniversity ✭✭

    I installed VS2013 Update 3 yesterday (8/13), and a number of beta channel Xamarin Studio updates, and now I can't build iOS projects.

    My C:\Program Files (x86)\MSBuild\Xamarin\iOS folder contains a bunch of new targets (all the MonoTouch files have been renamed to iOS), and the Xamarin.iOS.Common.After.targets file is causing the following build error... error MSB4057: The target "GetBundleResourceWithLogicalNameItems" does not exist in the project

    I don't know if this is a VS2013 Update 3 problem or a Xamarin beta channel update problem, but I've heard that switching to the Xamarin alpha channel may resolve the issue...

  • CraigDunnCraigDunn USXamarin Team Xamurai

    You mentioned the .targets filenames appear to have been updated - have you tried manually editing your csproj files and renaming the targets in there to match the new versions?

    I haven't personally seen this issue, but that's the first thing I'd investigate.

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    Installed, no problems whatsoever (mostly working with Android but not with iOS)

  • BoscoBosco USUniversity ✭✭

    @CraigDunn‌, no I haven't gone about renaming anything in project files, nor do I want to go screwing around with CSPROJ files. Furthermore, this isn't just a problem with my existing projects...

    I created a brand new solution, picked Xamarin Forms (Portable) project, accepted all defaults, and a new project named App1 was created. I did a full build of the new solution, and the same targets error comes up. The issue clearly isn't limited to my existing CSPROJ files, it's also a problem for all new projects.

    A co-worker suggested to switch to the Alpha channel and download the latest alpha updates... I did, and that fixed the build issue - my iOS projects now build successfully (after I logged into my Mac host and re-accepted the XCode license agreement). Unfortunately, none of my projects will run on the iPhone/iPad simulators - they all die abruptly just after the splash screen comes up, without any exceptions reported in the VS2013 debug window. The project I'm currently working on won't start, the FormsGallery sample won't start, a brand-new App1 solution won't start - iOS is currently as dead as Elvis.

    The Mac Server Log output in VS2013 shows...

    [14-Aug-2014 11:07:28] stdout: Starting iPhone Retina (4-inch)
    Launching application
    Application launched. PID = 1643
    Press enter to terminate the application
    >
    Application Terminated
    

    The Debug output in VS2013 shows...

    Getting device...
    Starting debug on:iPhone Retina (4-inch) iOS 7.1
    Launching Application for debugging...
    Starting debug session...
    The thread 0x1494 has exited with code 0 (0x0).
    

    My Android build is working fine, so I'm not totally blocked development-wise, but I need to get this iOS issue resolved pretty soon. I've been told this may be an issue with the VS2013 extension, but there's no update available for that yet.

  • CraigDunnCraigDunn USXamarin Team Xamurai

    I believe the Alpha channel contains our iOS 8 preview (which we've started posting samples for), which may explain the issues with the simulators (you didn't mention whether which Xcode version you have installed).

    In any case, someone's looking into it internally; if I hear anything helpful I'll let you know.

  • BoscoBosco USUniversity ✭✭

    @CraigDunn‌, found the resolution. And FWIW, I'm running Xcode 5.1.1 (5B1008).

    Visual Studio – iOS project properties – iOS Build tab – General – Linker Options… Linker Behavior = Link SDK assemblies only (was previously set to Don’t link)

    iOS projects now building, deploying and running successfully again! :-)

  • CraigDunnCraigDunn USXamarin Team Xamurai

    That's great - glad you're back in business. Normally Don't link is the safest option... I'll feed this back to the guys looking at the bug, since obviously we still don't want it happening!

  • MihaMarkicMihaMarkic SI ✭✭✭✭
    edited August 2014

    @CraigDunn‌ Now that I tried iOS for first time I am getting "error MSB4057: The target "GetBundleResourceWithLogicalNameItems" does not exist in the project." as well.

    Latest Xamarin Beta on both ends, XCode 5.1.1 on Mac 10.9 and Visual Studio 2013U3 on client. Any idea what to look for? Linker behavior doesn't help.

    Update: Same solution works when run from Xamarin Studio on Mac.

  • CraigDunnCraigDunn USXamarin Team Xamurai

    We're aware of an issue with GetBundleResourceWithLogicalNameItems on the Beta. Two other possible solutions above (changing linking settings, or trying the Alpha channel) are unconfirmed fixes.

    I'm not aware of a problem with our Stable channel.

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    OK, I see that's Forms only problem (i.e. Master-Detail "native" iOS app works), hopefully it'll be solved in next beta (fingers crossed).

  • StephenWilkinsonStephenWilkinson USMember ✭✭

    I am also seeing "error MSB4057: The target "GetBundleResourceWithLogicalNameItems" does not exist in the project." for VS 2013 U3 on our iPhone project. It's not a Forms project BTW.
    Changing the linker settings does not help. I have not tried it with XS on mac. I'll try reinstalling everything from "stable"

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    @StephenWilkinson‌ Perhaps is related to what libraries project use then? This isn't fixed in Forms 1.2.3 prerelease, which might support this theory.

  • StephenWilkinsonStephenWilkinson USMember ✭✭

    This does not happen with stable so I have not looked into any further "why" questions :) But if it helps - we use mvvmcross, akavache, splat, newtonsoft JSON, and all their associated dependencies - so finding out exactly what it is just simply would take too much time for me right now ;)

  • Same error for me: "The target "GetBundleResourceWithLogicalNameItems" does not exist in the project.". VS 2013 Update 3, iOS project (no Forms), last update on alpha channel. I've changed the linker settings with no results.

  • CraigDunnCraigDunn USXamarin Team Xamurai

    Last time I checked this error GetBundleResourceWithLogicalNameItems was happening in both Alpha and Beta channels; Stable should be fine and is what I'm currently developing with.

  • RobertAlmalakRobertAlmalak USMember ✭✭
    edited August 2014

    @CraigDunn‌ After the latest update of the Alpha channel I am getting as well the GetBundleResourceWithLogicalNameItems error. Going back to Stable and seeing if it will work. I am pretty sure this issue isn't related to Xamarin.Forms but more likely to be an issue with the xamarin libraries.

  • CraigDunnCraigDunn USXamarin Team Xamurai

    @RobertAlmalak‌ correct, it is not Xamarin.Forms-specific, affects a number of project types.

  • softlionsoftlion FRBeta ✭✭✭

    Hi,
    i just installed alpha channel and get this error in 3 iOS projects which compiles fine on the stable channel.

    error MSB4057: The target "GetBundleResourceWithLogicalNameItems" does not exist in the project.

    Target "GetBundleResourceWithLogicalNameItems" in file "C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.After.targets" from project

    I have VISUAL STUDIO 2013 UPDATE 2 only, so it is not related to update 3.

  • softlionsoftlion FRBeta ✭✭✭

    And i don't use Xamarin Forms. Affected project types are: PCL and iOS.

    Note that closing Visual Studio, reopening the project and building works fine. Log shows that all projects built are up to date.

  • softlionsoftlion FRBeta ✭✭✭

    well no need to close/reopen, just press CTRL-F5. This fails:

    Mtbs log:

    error MT0024: Could not find required file '/Users/xxx/Library/Caches/Xamarin/mtbs/builds/AcTouch/xx7e4e184ad9d2a11fe44bd7e5091fxx/bin/iPhoneSimulator/Debug/AcTouch.app/Info.plist'.

    Got connection from Visual Studio (log)
    Error: Error accepting log connection from Visual Studio
    Exception: Exception type: System.ObjectDisposedException
    The object was used after being disposed.
    at System.Net.Sockets.Socket.EndAccept (System.Byte[]& buffer, System.Int32& bytesTransferred, IAsyncResult asyncResult) [0x00000] in :0
    at System.Net.Sockets.Socket.EndAccept (IAsyncResult result) [0x00000] in :0
    at Mtb.Server.Proxy.LogProxy.VS_IncomingOutput (IAsyncResult result) [0x00000] in :0

  • softlionsoftlion FRBeta ✭✭✭

    Affected projects are PCL profile 49 only.

  • SandmanSandman USUniversity ✭✭
    edited August 2014

    VS 2013 update 2. Just updated to the alpha channel and I'm encountering the same.
    "error MSB4057: The target "GetBundleResourceWithLogicalNameItems" does not exist in the project"

    Changing the linker options didn't work for me.

  • CraigDunnCraigDunn USXamarin Team Xamurai

    As I mentioned earlier, the Stable should work fine.

    In general I would always advise working with the Stable channel, the Beta and Alpha channels are just that: preview releases that can have bugs (which we would love you to report). You should only use Stable to build and release production software.

  • softlionsoftlion FRBeta ✭✭✭

    Yes but the stable channel does not provide access to ios 8 beta ... And my app crahes on ios 8 beta and i can't debug ...

  • CraigDunnCraigDunn USXamarin Team Xamurai

    We have raised the bug internally based on beta channel feedback and it will be fixed in a future release.

  • SandmanSandman USUniversity ✭✭

    Sure, I would love to run stable build. But there are issues on Android that are only fixed in the alpha at this time. At the same time I'm trying to ensure I don't break my ios app.

  • FabioGFabioG ITBeta, University ✭✭✭

    I'm on the Alpha channel (Xamarin for Visual Studio 4.0.8.0, Xamarin.iOS 7.9.3.53). It looks like iOS projects don't compile if they reference a Portable Class Library.

    I get the same error as the other guys: error MSB4057: The target "GetBundleResourceWithLogicalNameItems" does not exist in the project.

    I've logged the following issue in Bugzilla:

    Bug 22428 - Visual Studio: iOS projects don't compile if a Portable Class Library is referenced.

  • CraigDunnCraigDunn USXamarin Team Xamurai
    edited August 2014

    @FabioG EDIT: oops my apologies, the other bug is hidden from you. it's a good idea to always search Bugzilla before raising "new" bugs, bug 22415 was already raised (and is marked as fixed, so it will be available in a future release).

  • FabioGFabioG ITBeta, University ✭✭✭

    @CraigDunn‌, no problem. I'm looking forward to the fix.

  • softlionsoftlion FRBeta ✭✭✭

    @CraigDunn It's good to verify that we can see the bugs ;)

    You are not authorized to access bug #22415.

  • CraigDunnCraigDunn USXamarin Team Xamurai

    hehe yeah, sorry about that. generally they are public (they should be by default) but occasionally one is marked private (when we first launched Xamarin.Forms this we discovered this happening a lot). i tagged the duplicate, and as I said it's marked as FIXED so hopefully you'll see the update soon in the Beta channel.

  • BrettMorrisonBrettMorrison USMember, University

    We're seeing this issue as well with the Alpha channel. Would be helpful if the bug #22415 visibility was changed so we can see progress on it.

Sign In or Register to comment.