Xamarin Studio 5.3 Push Notification error

BoogieMANBoogieMAN USMember ✭✭

I'm having problems using push notifications with the latest Alpha version of Xamarin Studio 5.3. After publishing on the device it pops a message saying "No valid 'aps-environment' entitlement string found for application". Any help with this, anyone? Thanks...

«1

Posts

  • KatalysticalKatalystical USMember
    edited August 2014

    Same Problem here, I'm still investigating the issue, but it seems it happens since the last beta channel update for 5.3.
    Switching to Stable channel right now.

    I removed every certificate and provisioning profile, dirtied everything/revoked it in Apple Dev Center, re-created it and re-installed it, also with removing everything from the tester's mobile phones.

    I even cleaned the Library/MobileDevice/Provisioning Profiles/ directory. I still wonder about cleaning some Xcode Temp dir?

    Every prov. profile seems to have the aps-environment key in it, it must be some kind of zombie provisioning profile, misconfiguration during the update process or a bug in the compiler/XStudio itself.

    Greetings from Germany,
    Kevin

    EDIT: Switching to the current Stable release fixed it. I just did a cleanup (as I always do) and re-compiled/ran the debug. No issues. Therefore, this implies a bug in the Alpha/Beta branch. I checked Bugzilla for any open (and already closed) tickets regarding this or similar issues with no success.
    During the last few Beta channel updates, I always had to sudo and change Permissions (see https://bugzilla.xamarin.com/show_bug.cgi?id=21474#c3), but in the last update (the one which introduced the aps-environment bug) this was not neccessary. I'm quite sure this has nothing to do with it, but there's at least the possibility of a relation, though this would be quite odd. (I had to do the chmod-trick after installing the current stable release).

  • BoogieMANBoogieMAN USMember ✭✭

    I am using the alpha channel with Xamarin.iOS 7.9 but using Xamarin Studio 5.2. That's the only way to make the apps working on real devices.

  • Greg767Greg767 CHMember ✭✭

    OMG!!! I've been pulling my hair about this issue for days and I was thinking I had a problem with my certs so I kept re-creating them...
    So I can confirm, with XS 5.2.1 and iOS 7.4.0.104 the problem disappeared. I was on beta channel just before.
    Thanks guys,
    Greg

  • JohnCHarrisJohnCHarris USMember ✭✭

    Thanks for this. I was going crazy with my certs as well.

  • I was just about to give up!!!!! Downgrading now...

  • icnatejacksonicnatejackson USMember, University

    Same issue here. entitlements that are clearly in the provisioning profiles are not making their way into compiled apps. As of 9/2/2014, the only channel that it works on is the Stable Channel.

    Xamarin Studio Version 5.2.1 (build 1)
    Xamarin.iOS Version: 7.2.6.28 (Business Edition)

    Nothing else works today.

  • leiz_caleiz_ca CAMember

    Well, as of Sep 2, 2014, Stable Channel's Xamarin Studio 5.3 (build 440) and Xamarin.iOS 7.4.0.108 (Business Edition) does not work....
    How to revert back to 5.2.1 ?

  • BoogieMANBoogieMAN USMember ✭✭
    edited September 2014

    For those of you who want to downgrade, go here and follow the instructions.

  • prashantvcprashantvc USXamarin Team Xamurai

    @leiz_ca‌ & @BoogieMAN‌ it sounds like bug in latest version could you send us the complete build log and version information from Xamarin Studio?

  • BoogieMANBoogieMAN USMember ✭✭

    @Prashant‌: Right now any version prior to 5.2.1 is having the same issue. I installed the latest alpha version (5.4) and is having the same problem too.

  • Yep, it's back. The latest stable release of X.iOS 7.4 / XS 5.3 made my app useless. @Prashant Any contact info regarding buildlogs? (PM?)

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    Hey All,

    For those of you running into this issue, please email [email protected] and attach the *.xcent file that _should_ be in your bin build directory. Please also include your Xamarin tooling version information in the email. The easiest way to grab this is by opening Xamarin Studio, navigating to the About Xamarin Studio -> Show Details menu. You can then click the Copy Information to grab all the version data to paste into the email. If you are using Visual Studio, go to the Help -> About Visual Studio menu and click Copy Information.

    Thanks!

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    A quick check you can do is to use plutil -convert xml1 ProjectName.xcent.xml ProjectName.xcent (the xcent file should be located next to your .app bundle directory under your bin directory) to convert the xcent file into readable xml and then open it up and check for the aps-environment key. If it is there, then we are still merging the Entitlements from the provisioning profile. If not, then we aren't... and apparently we need to be.

    To work around this problem, open the embedded.mobileprovision file in your app bundle and you should find an "Entitlements" section in the XML (surrounded by binary data).

    Look for the aps-environment key and copy the key/value pair.

    Now open your Entitlements.plist file in your project and paste the key/value pair into it.

    Once you recompile, it should be fine.

    I recently patched Xamarin Studio to no longer merge the Entitlements from your provisioning profile because we were getting reports saying that this broke codesigning for some customers. I think it made it into 5.3 and that it is probably what is causing this problem.

  • Greg767Greg767 CHMember ✭✭

    As John requested I emailed the xamarin support. Its quite an annoying problem, hopfully it will get fixed soon.

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai
    edited September 2014

    Thanks, I have gotten enough .xcent files to confirm what Jeff has stated. Please see his comment above.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    This will be fixed in 5.4

  • icnatejacksonicnatejackson USMember, University

    guess I'm not upgrading my stable channel today....

  • BoogieMANBoogieMAN USMember ✭✭

    @JeffreyStedfast‌ when will be able to upgrade? any timeframe?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    After iOS 8 and Xcode 6 final are released

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    I've proposed a hotfix patch for 5.3 - I suspect that it'll be accepted as long as QA can reproduce the problem.

    Are you just enabling push notifications for the app and trying to run it on device?

  • BoogieMANBoogieMAN USMember ✭✭

    Exactly, that's the only thing needed to reproduce the error.

  • MichaelKniskernMichaelKniskern USUniversity ✭✭

    Is this error also impacting Visual Studio? I am getting the same error where I had push notifications working on my iOS version of my application when I had resolved this error over a few weeks agos. I looked in my Entitlements.plist and can not find any of the settings needed for enabling push notifications.

  • ATS2050ATS2050 USMember

    It's unclear above whether downgrading or upgrading to the latest beta / alpha will help this. Anyone know?
    We cannot enable push notifications due to this error.

    P.S. Any timeframe on the hot fix? (Please tell me before the weekend :))

  • shanminxushanminxu USMember

    waste me half day. reinstall v5.2.1 then works.

  • MichaelKniskernMichaelKniskern USUniversity ✭✭

    Does this .xcent settings override the setting you put in your entitlements.plist file?

    Can you view .xcent file on a windows computer? Is it only please visible on a Mac?

    I have put all of my required push notifications settings in the entitlement.plist file and the application just seem to ignore them.

  • This is totally wasting time to find the problem only, can we get the hot fix asap.
    Or Please provide the downgrade steps asap.

  • AlexWhiteAlexWhite GBMember ✭✭✭

    This problem has just cost me two days of banging my head against a brick wall, having reinstalled everything Xcode etc, rebuilt the certs and the profiles to find that the issue (which still does not work) is not related to any of the above, the last release of XS has not been a good one for me, still littered with bugs (which I have reported in the past).

  • AlexWhiteAlexWhite GBMember ✭✭✭

    I would like to make a point here, this issue screws up a complex system, a system that takes a good couple of hours to configure if you know what you are doing (creating certs, converting them, binding them into an app for the push notifications), creating profiles testing them etc, these types of issues should be broadcast to the entire Xamarin community because I hate to think how many people have their heads in their hands right now saying 'what have I done wrong, this worked a few days ago'.

    I fully appreciate issues creep into systems, its what you do about them that matters

  • NicoDekkerNicoDekker NLMember ✭✭

    Can someone please state which settings should be available in the Entitlement.plist file? Mine looks a kind of empry ;)

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">


  • EricFontanaEricFontana USMember ✭✭

    I just wasted the entire day yesterday, re-creating my certificates, etc. submissions to Apple only to have them rejected
    because of missing aps key(s), which I tracked down to a bad .xcent file which was being generated. Only because of this thread, I went back to version 5.2 and it fixed the problem. This a pretty bad bug and needs a hotfix today.

  • MatthewMatthew USMember

    Any idea on if there will be a hotfix soon? I have a presentation on Thursday and could do without re-installing 5.2.

  • BoogieMANBoogieMAN USMember ✭✭

    For the people who are still having issues with push notification on the latest version of Xamarin, you need to follow the instrucction here

  • MatthewMatthew USMember

    are there any issues removing the current version? I would rather not have to re-install

  • BoogieMANBoogieMAN USMember ✭✭

    You don't need to reinstall everything, just delete Xamarin Studio from the applications folder and copy de the older version there.

  • GerryHallGerryHall USMember

    Is there any ETA on the hotfix? This is a huge blocker to our development cycle as it would be a painful process to downgrade multiple developers.

  • SukhmeetSukhmeet USMember

    I also wasted a lot of time trying to re-create Certs, profiles, etc.
    Curious to know ETA on the hot fix.
    I wonder, How something like this even pass the QA process ?

  • BoogieMANBoogieMAN USMember ✭✭
    edited September 2014

    @Sukhmeet‌ that's true, at first I though it was a problem with the version I was using of Xamarin (Alpha 5.4) but then I notice I was having the same problem on Xamarin 5.3. This is a BIG bug that shouldn't has appear on the first time.

    I hope they release the fix tomorrow if Apple releases iOS 8 and Xcode 6.

  • SukhmeetSukhmeet USMember

    Thank you Victor. I will wait for the fix.

  • Maico2007Maico2007 MXMember ✭✭

    I had the same problem, I returned to version 5.2.1 and generated certificates and has returned to work.

    Thank you.

  • Incredibly, amazing, bug. As a lot of developers I wasted exactly 8 hours of my developer time with hands in my head, lost lots of hair, one week delay caused by a rejected app on app-store, 3 hours of wasted extra-time with no additional payment, and 1 fight with my girlfriend. Last Friday I had to return to 5.2.1 (uninstall crappy XS, download old version -which is very difficult to found and reinstall....that solved the problem. Now on Monday, as far as I understand, it is not solved on 5.3.....are you kidding us? what is the matter XS Team? Did you really expect that we trust XS after this? Are you trying to push us to pay for a Enterprise edition for the HotFix support?....No one of the team give a little answer nor apologises...unbelievable

Sign In or Register to comment.