My first real X.Forms app, trouble getting it to work on Droid

JohnHJohnH GBMember ✭✭✭✭✭

I started this over in the Droid forum as thought it might be a generic Droid issue, turns out that a new Droid app works fine, but a new X.Forms app on Droid does not.
I created a brand new X.Formed Shared Library solution containing iOS and Droid. Compile and run as iOS, works fine. Compile and run as Droid, it starts the app but appears to hang with the app title along the top. Eventually the OS tells me it has stopped responding.
Any suggestions on getting past this? I can place a breakpoint in the default GetMainPage() method and it runs the code, it just doesn't render anything on screen.

Posts

  • GeoffArmstrongGeoffArmstrong CAMember ✭✭

    Yes, there's a bug in Xamarin.Forms 1.2.1 when it comes to running Android applications. They're fixing it.

  • JohnHJohnH GBMember ✭✭✭✭✭

    Wow that was a quick response thanks Geoff!
    Is there a work around? I presume not. Do they not have Droid apps included in unit testing? Or is it very specific scenario's where this breaks?

  • GeoffArmstrongGeoffArmstrong CAMember ✭✭

    Best I could offer per http://forums.xamarin.com/discussion/comment/65384/#Comment_65384 would be to add a navigation page at the root of the hierarchy... but I'm not sure.

    We're working on a cross-platform XF app and just basically switched to doing all development and testing on iOS while waiting for the bugfix.

  • JohnHJohnH GBMember ✭✭✭✭✭

    1.2.2 pre release is out which fixes the initial problems I found, thanks for the assist Geoff!

Sign In or Register to comment.