AntiVirus issue with Mac OS X install?

groundh0ggroundh0g USMember

The download and installation of Xamarin Studio and all the supporting tools worked flawlessly on my MBP / OS X.

During installation, my antivirus flagged two of the userdata.img files (under SDK 12 and SDK 14, IIRC) as a Trojan.

I'm typing this from memory, but I think the AV (ClamXav) quarrantined the files after detecting ANDR.Trojan.GingerBreak.

I updated my AV preferences to ignore those two userdata.img files, then moved them back to their SDK homes.

Everything seems to be working just fine. Just curious if anyone else ran into something similar.

Posts

  • groundh0ggroundh0g USMember

    Ugh. Guess it's obvious, but I didn't mention that those files were a part of the Android virtual device installs.

  • fritsmfritsm NLMember

    Hi,

    Yes, I got the same warning from clamXav OSX about this GingerBreak Trojan. Not sure what to do.
    Xamarin Studio 2.0 Starter Edition, fresh install.

    Frits

  • groundh0ggroundh0g USMember

    I trust Google and Xamarin. Assume it was a false positive. Here's what I did:

    1. Launch ClamXav from the menu
    2. Click Preferences
    3. Click Exclude Files
    4. Add a new RegEx entry (make sure it's enabled)

    "MonoForAndroid API [0-9]+\.avd\/userdata\.img$"
    (without the quotes)

    You can reinstall if you like. I was able to determine which quarantined file came from which folder, so I just moved them back.

    Hope that helps.
    -- Joe

Sign In or Register to comment.