Tasky: Deployment failed. Assembly synchronization error - help

I am complete new "MonoToucher" and need help

My plan is to break down the Tasky app and show other team member and IT architects how it works.

This is what I did:

  1. Installed Xamarin Studio on a well-equipped MacBook Pro - OK
  2. Executed Tasky on iPhone device – OK Worked perfect
  3. Executed Tasky on Android device - ERROR
  4. Executed Tasky on Android Emulator – ERROR (looks similar to #3)


First everything looking the business. Runtime and App was transferred and installed.
Next after the “Synchronization Assemblies” it raise an error: Deployment failed. Assembly synchronization error

What can be wrong?
I have googled the issue without luck (I will try some more)

Another thing I listed was that latest version is level 15 (4.0.3). This is not always a showstopper but if we need to some features introduced in newer versions we need a plan for that. I also listed that there are not backwards capability, or what I can see I may add, in the Tasky project.

I understand that libraries must be will tested before launched but level 15 is almost three years old.
Is this correct?

Thanks in advanced
Stephan - Norway


  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @StephanCassel‌ Make sure you can build the Android project and make sure the Build Configuration is set to Deploy. Those apps should run by themselves after cloning the source and opening the solution. Other than that, can you provide your output log when trying to run?

  • StephanCasselStephanCassel NOMember

    Thanks Jon,
    I have been away for some days.
    I will give it a try

  • StephanCasselStephanCassel NOMember

    Works fine :-) That means that I am not able to debug the app on a real device?

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai
    edited June 2014

    You still can! For Android: Connect a phone, make sure you install it's drivers, and debug away! There's a bit more setup for iOS, so take a look at the docs there.

  • StephanCasselStephanCassel NOMember

    Great. I should try instead of asking. Children are master of trying but when you get older........ :-)

  • ahmadal-sadiahmadal-sadi USMember

    when i run my android application in my device i got this message "assembly synchronization error"
    how can i solve this problem

Sign In or Register to comment.