Forum Xamarin.Android


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Android Emulator Debugging Not Working

BrianMainsBrianMains USMember
edited July 2013 in Xamarin.Android


I created a simple Android app. In Xamarin Studio for Mac, I select start without debugging. It opens up the list of default emulators. I chose api 8 emulator. Emulator runs and shows android shell, but my app doesn't load, and it's not in the apps list. It never ends up loading. I tried other api versions too. Is there any trick to working with the emulator??



  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    Moved to Android forum

  • PierceBogganPierceBoggan USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    @brianmains, I assume this isn't project-specific? I also assume that you are able to select the emulator after it boots up and attempt to install your app on the device.
    When exactly are you encountering the error?


  • NckNck AUMember

    Every android sample app i have tried appears not to be deployed to the emulator. dont see it under apps. one of the emulators flashes red around outside and appears to reboot. no build errors at all

  • NckNck AUMember

    using xamarin studio

  • NckNck AUMember

    all sorted.
    running the project didnt work.
    needed to start device first (x86) then upload the app to started device

Sign In or Register to comment.