Forum Xamarin.Android

"Can't create project with type: MonoDroid" when adding a new project

JavierJJavierJ USMember ✭✭

I am trying to evaluate the Xamarin tools and I've run into what I think are some installation issues. I originally had the Eclipse ADT on my system and it was working properly. Then I installed the Xamarin tools and they were working OK, but when I checked my original Eclipse ADT, it started raising issues. After trying to figure out what was going on, I ended up uninstalling both Xamarin (including the other packages added by the installer: Gtk and Android SDK), the Eclipse ADT, and even the Java JRE and JDK.

I reinstalled only the Xamarin tools using the XamarinInstaller. Installation went OK but when I run Xamarin Studio I get the following problem: When I try to create a new Android project, I get a message indicating that the "MainActivity.cs file cannot be found" and the project is not created. If I try to add the project to the solution, I get the message "Can't create project with type: MonoDroid" and Xamarin Studio raises an error (attached). After that, I get errors and if I exit Xamarin Studio, it closes the IDE but the process stays in memory.

Can anyone provide any clue of what is going on and how to fix? Thx.

Best Answer


  • JavierJJavierJ USMember ✭✭

    BTW, I am using Xamarin Starter (I am trying to evaluate the tools) and the OS is Win7 x64.

  • ajitgoelajitgoel USMember

    @JavierJ : I still have the same issue. When I run the installer, It just fails. It logs the following error:
    Did not find Xamarin.Android

    Can you please help?

Sign In or Register to comment.