Forum Xamarin Xamarin.iOS

How can I target an older OS X SDK from Xamarin Studio?

We are building a Xamarin app that needs to run on OS X 10.6 through 10.9. If we use the newest Xamarin tools on a OS X 10.9 development machine, and set the Deployment Target to 10.6, it will build against the 10.9 SDK and will NOT give compiler errors when we use API calls that are not available in OS X 10.6. This makes it quite impractical to say the least to develop for an older OS, so there must be a better way. So: what is the better way?

We have installed old versions of MonoDevelop and the Mono 2.x MDK on an old OS X 10.6 machine and that will give us the compiler errors, but since it runs on Mono 2.x we're not sure if the behavior will be comparable with Mono 3.x

I know Apple does not encourage developers to develop for older OS versions, but we can't force our users to upgrade their system, and we can't be the only one I guess.

Answers

  • ChrisBrunoChrisBruno USMember
    edited April 2014

    Your best bet is to develop on 10.7 and target the 10.7 SDK. That will have the least difference in the APIs from 10.6.

Sign In or Register to comment.