Forum Visual Studio
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Trying to get IPA built from visual studio

I keep getting errors like "Failed to open Finder on the build server Xamarin.iOS Extension"
and "Failed to open Finder on the build server Xamarin.iOS Extension"

This seems to happen only on ad-hoc build?


  • seansparkmanseansparkman USInsider, University, Developer Group Leader mod

    I am also having this problem.

  • RyanManwillerRyanManwiller USMember
    edited February 2014

    Same problem here. Can't build an ad-hoc ipa in xamarin iOS visual studio. I get:
    Remote build error while building adhoc ipa.
    Failed to open finder on the build server.

    I was able to get the ipa build to succeed by checking the Build Host Log on the Mac. In the build host app, choose View Build Host Log from the app menu.

    In that log, I could see Error: the provisioning profile 'Automatic:Adhoc' could not be found.

    So I went back to visual studio, project properties, iOS Bundle Signing and changed the profile from automatic to my adhoc test profile.

    Then the build worked.

    But, I still don't get the ipa file to show up on the windows machine. I have to fish around on the mac to find it under: /user/Library/Caches/Xamarin/mtbs/builds/....

    Should the ipa be getting copied back to windows somewhere? It's not under project/bin/iPhone/AdHoc

  • shribshrib USMember

    Is there a solution or Acknowledgement to this issue? Is this something we (devs) are doing incorrectly? Or is this a known issue... fix on the way kind of scenario? Some guidance here would be good!

  • AbePleasantAbePleasant USMember ✭✭

    Also having this issue. I think I got around it once by updating xamarin.ios, restarting VS, but now I have done that again and it still won't work. This is definitely an area where xamarin needs to improve :(

  • AbePleasantAbePleasant USMember ✭✭
    edited March 2014

    Well here is what worked for me (currently anyway, I hope it doesn't break itself again):

    1) Update Xamarin.iOS for VS (and I was forced to update Xamarin.Android in the process, but I digress..) and restart VS

    2) Update Xamarin.iOS on the mac build host (maybe this should have been step 1?)

    3) Update Xamarin.iOS for VS again, and restart VS

    4) Confirm that you can select the Distribution certificate and the Ad-Hoc Profile inside of VS

    5) Clean and Rebuild the iOS App project and all the projects it needs

    6) Click "Publish iOS Application"

    Afterwards on my mac build host it automatically opened a Finder window to the folder containing the IPA file. Sorry this is not a real explanation of why the IPA wasn't being generated before, but I'll let the Xamarin team answer that one :-)

  • RobertTakefmanRobertTakefman USMember ✭✭

    Found it after hours

    In visual studio 2015, set solution configuration to 'debug' and solution platform to 'iPhone'. Under solution configuration, I didn't find any Ad-hoc option.

    Goto 'your_ios_project.iOS' properties-->ios Bundle signing, change identity from 'developer(automatic)' to 'iPhone Developer:xx..x(xx..)'

    Build the iOS project. After the build succeeds the IPA file gets generated both in your windows bin folder as well as in the MAC.

Sign In or Register to comment.