Forum General


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

How can I access to txt file in my samsung galaxy watch

mommekmommek Member ✭✭

Hi, I do my reseach on google, but I don't find any solution for my problem. I have my galaxy watch app in xamarin and tizen and I have simply method to write my log data into log.txt file:

    public static void writeLog(string text)
        string fileName = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "shared.res.log.txt");
        string now = DateTime.Now.ToString("");
        File.AppendAllText(fileName, now + " " + text + "\n");

This is working, because I have log page on my app and it shows my data. So there really is log.txt file, I suppose on /shared/res/ folder.

So... How I can download this file to my PC? I'am using Visual Studio 2019 + Tizen Device Manager for pushing my app to my watch. In tizen device manager I have access to probably all files in my watch, I even see this file but I can´t downloaded it :( see screenshot.

I dont have any of those characters in my txt file when I open it from my watch.

Any advice? :-)


  • Gustavo_OliveiraGustavo_Oliveira USMember ✭✭✭

    Hi @mommek, what about exporting the file to your common folders, such as Download or Documents?

  • mommekmommek Member ✭✭

    Hi @Gustavo_Oliveira thanks for your reply :smile: Do you mean exporting file in my watch app to other folders? Remember, that I develop watch app, not mobile app where it is many times easier :) I need connect my watch to my PC (only via tizen device manager through wifi) and from there I can see all files in my galaxy watch, but it is not possible to open or download it :(

  • Gustavo_OliveiraGustavo_Oliveira USMember ✭✭✭

    Have you tried changing the Properties > Permission as described here

  • mommekmommek Member ✭✭

    OK this help, I can pull file to my desktop now, but it is empty :( When I open this exactly this file in my watch app, its full of informations. So I suppose I must be at wrong place / wrong directory?


  • JimmyJWJimmyJW Member

    Strange, it shouldn't display like that. Have you already solved the problem?

  • mommekmommek Member ✭✭

    @JimmyJW unfortunatelly no :-(

Sign In or Register to comment.