Forum Cross Platform with Xamarin

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Running the xamarin.UWP project causes Unhandled exception at 0x6671B076 (twinapi.appcore.dll)

I created a new cross platform app using Xamarin.Forms in Visual Studio 2017 on windows 10. The project can get built but when I run it, I get 'Unhandled exception at 0x6671B076 (twinapi.appcore.dll)' exception.
Any one has any idea to solve this issue?!

Answers

  • kentuckerkentucker USMember ✭✭✭✭✭

    Sounds like something is wrong with the store cache on your machine. From an command prompt running as an admistrator run the command wsreset.exe. This will attempt to repair the store.

  • jackjafarijackjafari USMember ✭✭

    I ran wsreset.exe and it ran app store but it didn't solve the issue.

  • kentuckerkentucker USMember ✭✭✭✭✭

    Go to the microsoft store on the computer and try and install a new app from the store. Does it install?

  • jackjafarijackjafari USMember ✭✭

    Thanks Kentucker,

    The other apps worked fine, I even had another Xamarin app and was able to debug it.
    However I eventually had to reset my windows and after that it got fixed.

  • MichaelKayMichaelKay GBMember ✭✭

    Hoping someone can help me. I've created a Xamarin Forms project in VS 2017 Community version and trying to run UWP (Universal Windows) app on a Winodws 10 machine. I keep getting this error too?

    My error is: **Unhandled exception at 0x6D15B076 (twinapi.appcore.dll) in AppName.UWP.exe: Fatal program exit requested.
    **
    I've tried to set the debugger type of Native Only, Mixed and Managed but none of the option works. I even uninstalled VS 2017 and re-installed, still no luck. I've ran update on the software and machine.

    Any idea how I could solve this issue. I'm really at a lost here.

  • MichaelKayMichaelKay GBMember ✭✭

    Coming back to this, I actually got this working successful on a clean VM. Not sure why I could not run it on my physical device? For now I can use the VM for building UWP project.

  • okinaturokinatur Member ✭✭

    I never believed that this kind of problem would cause me problems in 2021 on my PC for the missing DLL file named twinapi.appcore.dll. I found it on some websites it seems legit site like Dllinstaller.com should I download the file from the site or there is another way to fix it.

  • okinaturokinatur Member ✭✭

    I download the missing twinapi.appcore.dll file but the error steal is popping up appears on my PC, what is the problem now?

Sign In or Register to comment.