Forum Xamarin.iOS


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

error MSB4022: The result "" of evaluating the value "$(MicrosoftNETBuildExtensionsTasksAssembly)"

nathan187nathan187 USMember ✭✭

have to do some work on an older application. i am getting this error

error MSB4022: The result "" of evaluating the value "$(MicrosoftNETBuildExtensionsTasksAssembly)" of the "AssemblyFile" attribute in element is not valid.

a little annoying that every time xam is updated, it's going to break just about anything.

this project is old and i have to use the mono runtime 4.8.1 (project uses fody). cleaning the solution just hangs using this runtime. i tried running it using a different runtime and i get either a fody exception or that weird error above

i tried closing and restarting visual studio 2017. i also tried remove bin and obj folders

any help would be nice, thanks in advance

Best Answer


  • nathan187nathan187 USMember ✭✭

    @ElvisXia thank you for taking the time to respond

    i am not sure if i explained it as best as i could...sounded pretty generic...however

    i was able to fix the issue (surprisingly). i updated the fody packages (fody, asycnerrorhandler.fody, and propertychanged.fody). i also updated the xamarin.forms packages in the pcl and the ios project. some cleaning, deleting bin and obj directories...and to my now works

    i hope i didn't waste too much of your time.

  • ManishJain.2477ManishJain.2477 USMember ✭✭
    edited June 2019

    So, on Mac Mojave after VS2019 (8.1.3) upgrade, I ran into the same issue.
    I tried above. Removed UsingTask from Xamarin.iOS.Common.targets and now getting below.
    Getting restore information for project /Users/user/Projects/sample4/sample4.Android/sample4.Android.csproj
    Value cannot be null.
    Parameter name: key
    So, I create a new blank project and it doesn't work! Great!!

  • nathan187nathan187 USMember ✭✭


    hi Manish....i have come to realize that when dealing with this product (xamarin/visual studio)....that you have it install on more than one machine. in the past i worked with a contractor and he would always roll his eyes (we would work on the same project) when i told him i upgraded to the latest version of visual studio.

    at home i have an imac and a mac book pro. the laptop is always a release or two behind because every time i upgrade xamarin/visual just will not work and i have to spend days getting older applications to compile.

    no difference here. recently we had to change a freaking entry to a resource file. i upgraded visual studio and now, the app will not compile/clean. it just hangs when trying to clean and the detailed error message is: MonoDevelop.Core.Execution.RemoteProcessException: The operation failed due to an internal error: MSBuild operation failed"

    so now i know..not to upgrade xamarin on my laptop here or the work issued laptop. there have been times that i have to leave the office to go home and work because visual studio wouldn't compile my projects on the office computer after an upgrade.

    i remember how upset we were when the decision was made to move to ionic. it doesn't seem like such a bad idea now

  • EdwinKlesmanEdwinKlesman USMember ✭✭

    Although this is an old post, I recently got the same issue on my Mac with VS version 8.8.10 (build 2).

    After restarting VS and opening my Xamarin.Forms project I noticed a notification bar at the top stating that I needed to install the command-line toolkit. Probably since XCode was updated on my machine and VS needed to update it.

    After installing this and cleaning my project, things were set straight and I could manage packages, build etc.

    Hope this helps someone in the future.

Sign In or Register to comment.