Forum Xamarin.iOS

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Cannot archive project with Notification Service Extension

NickKovalskyNickKovalsky USMember ✭✭✭
edited June 2020 in Xamarin.iOS

Further to this question https://forums.xamarin.com/discussion/comment/412962 still failing to archive my solution to get an IPA, getting a funny "ditto exited code 1", looking into logs shows

Could not find a part of the path "/Users/Username/Library/Caches/Xamarin/mtbs/builds/BlaBla.iOS/c53f41a2a149592e299c552833a05746/F:/BlaBla/Src/BlaBla.OneSignalNotificationServiceExtension/bin/iPhone/Release/OneSignalNotificationServiceExtension.appex/Info.plist".

Obviously this is a release version, compiled ok, but not archiving. What i don't get how come the archiver wants to access path "..5746/F:/Bl.." with a semicolon character what is not allowed. I indeed has a path on mac disk with "..5746/F//Bl.." without semicolon that was replaced by "/". Xamarin bug? Visual studio bug? Already cleaned caches, binobjs and stuff, restarted everything tons of times.. Thoughts?

Edit: Created another project from scratch from xamarin templates, gives same error.

Answers

  • ColeXColeX Member, Xamarin Team Xamurai

    The error is happening because it can't find the info.plist in extension project when archiving application .

    Try to delete bin and obj folder , and remove extension from solution and add it again .

    If problem persists i suggest you move project to visual studio for mac for archiving .

  • pchampcham Member

    I'm facing the same issue. Tried deleting the bin/obj folders but it did not help. Any help would be appreciated

  • NickKovalskyNickKovalsky USMember ✭✭✭
    edited July 2020

    This totally looks like xamarin.ios bug, filed it https://github.com/xamarin/xamarin-macios/issues/9007. The app compiles, deploys and runs fine using release ad-hoc on real device, while archiving from windows just fails with above error.

    Anyone knows if it's possible to archive compiled files into ipa directly on mac without rebuilding the solution on mac?

  • pchampcham Member

    A workaround I found was to enabled the IPA packaging option under the ios properties in VS 2019 and then connecting to the MAC build host to build the project. I managed to get the IPA file under the ios_project\bin\iPhone\Release folder. I was able to deploy the app to test on Testflight using the transporter app on the MAC.

  • We tried pcham's solution but it didn't work. We still have this problem and it keeps getting passed around by the Feedback Bot.

  • rp66rp66 Member

    Any update for this issue?

    If looking for the missing info.plist on the Mac, I noticed that the complete folder for Notification Service Extension is missing on Mac, but existing on the windows machine. Files for the standard iOS project are existing on the Mac.

  • NickKovalskyNickKovalsky USMember ✭✭✭

    As far as i remember managed to compile it from Windows using VS 2019 preview version, but still couldn't get the extension to work, it just wasn't called upon receiving notification.. If you do please share your success story :)

  • legionlegion Member

    I had this problem as well. I tried everything and I could not get it fixed. Have had this problem for 2 months now.

    In the end I switched to an older laptop with an older version of Visual studio(16.7.5) with the Xamarin iOS package 14.0.0 that Visual studio will sync with the mac automatically.

    With that setup I was able to build and this is still how I do it.

  • Vaclav_DajbychVaclav_Dajbych CZMember ✭✭

    I also have this problem. Sometimes it works, sometimes it doesn't. I have no idea what's wrong.

  • rp66rp66 Member

    Up to now my only chance to Build the Notification Service Extension is to build it directly with Visual Studio on the Mac.
    On Windows machine I get the same error all the time.
    I wonder that you only get the error sometimes.

Sign In or Register to comment.