Forum Xamarin.iOS

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Can't open storyboard in Visual Studio for mac "Did not find files to open at path..."

NaboNabo SEMember ✭✭

Had a bit of summer break and now I can't open the storyboard file with Xcode interface builder from VS for Mac anymore. The error in Xcode says "Did not find files to open at path.(/Users//obj/Xcode/0/Resources/Base.lproj/MainStoryboard.storyboard)". In Finder I cannot find the "Resources" folder in the "0" folder. Any tips would be helpful...

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    It seems VS for Mac didn't transfer the file to the XCode's directory.
    Have you tried to open it directly in VS for Mac? A storyboard could be opened in VS too. You could check its properties there.
    Or find it in your project's directory and double click to open it with XCode.

  • NaboNabo SEMember ✭✭

    Yes, opening it in Visual Studio for Mac works but the UI for working with e.g. auto layout is not "optimal" in VS 4 mac. I'd love to be able to just do everything in VS but I'm having a lot of issues storyboard editing in VS, so as it sits right now I prefer working with it in XCode.

  • LandLuLandLu Member, Xamarin Team Xamurai

    You could try to open the file in the directory with XCode instead of choosing XCode in the VS.

  • NaboNabo SEMember ✭✭

    This kind of makes my point as well... :)

    If I try to edit the file in XCode anyway, when syncing it creates new .cs and designer.cs files for all my classes in the Base .lproj folder instead of updating in the folders where I already have the files.

  • NaboNabo SEMember ✭✭

    Tried uninstalling and re-installing visual studio for mac with no luck...

  • kanderwellkanderwell Member ✭✭

    I hit this as well. I also found that just opening the file from Finder didn't work either, I had to have XCode open and then find and open the .storyboard file manually from the File menu. Now I have to figure out how to get the Assistant open for click-dragging outlets...

  • @kanderwell have you managed to open Assistant editor for click-dragging outlets? I have same issue...

  • kanderwellkanderwell Member ✭✭

    Just to have the whole procedure in one place, I'll reiterate my previous post and describe the next step:
    1. Find the .storyboard file via Finder and open it in XCode (I said earlier I had to open it up from XCode but that doesn't seem to be the case now, but either way that works for you is fine)
    2. Find the .h file via Finder and open it in XCode (the .h file is built by VS at the moment you attempt to open the .storyboard file from VS, so even though it will fail you need to try to open it and the .h file will then exist and you can search for it by name in Finder) (things might also get weird with changes getting propagated back down again, so make sure to do an open attempt again later after saving your changes and closing XCode)

  • This is apparently still broken. I can't edit storyboards in VS for Windows or in xcode. Yikes.

Sign In or Register to comment.