Deploying update to Apple App Store - version number fails

I have uploaded my first app to the app store, and it was version 1.0. Now I have an update to load, and in my info.plist file I have updated the version to 1.1 However, when I try to upload using Xcode organizer, it fails stating that the bundle's version number needs to be higher than version 1.0? Not sure what to do? Any suggestions?

Posts

  • Bob_ReckBob_Reck USMember ✭✭✭

    @ScottSmith,

    Be sure you are changing the build and version numbers on the iOS Application section of your info.plist. The way I always get to this is to right click on the project file (not your solution file) and then click on "iOS Application" under the "Build" section.

    There are two fields... one for Version and one for Build. I always set them to be the same. So in your case, you should have "1.1" in each field.

    When you build your app for release using the AppStore configuration setting, your app should build with the correct version number in the IPA file name.

    Bob

  • ScottSmithScottSmith USMember

    Thanks Bob. I finally thought of that about 9:30 PM last night. And not updating the build number was the issue

Sign In or Register to comment.