Forum Cross Platform with Xamarin
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

DEP0700 problem with UWP in Xamarin since VS2019 upgrade

I recently upgraded from VS2017 to 2019 Community. I have had continuing problems since then
I've re-installed VS2019 multiple times and cannot figure out what is happening, slowly losing my mind.

When trying to run a UWP App - a simple app, no changes from the default when you create a blank app - I run into this error

Error DEP0700: Registration of the app failed. [0x80073CF3] Windows cannot install package e62688da-42c4-44b3-8385-93c5b1a8343d_1.0.0.0_x86__ddkvg3xhjcywc because this package depends on a framework that could not be found. Provide the framework "Microsoft.VCLibs.110.00.Debug.UWPDesktop" published by "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x86 processor architecture and minimum version 11.0.61135.0, along with this package to install. The frameworks with name "Microsoft.VCLibs.110.00.Debug.UWPDesktop" currently installed are: {} AppTry.UWP

I do not know how to proceed, and haven't been able to Google a solution for getting the VCLibs .110 framework.

This is on my desktop, but Interestingly, things are working on my notebook which I thought was set up the same way, I can do UWP and Android development fine, include my primary more complex app I have moved over from VS2017. So this seems to be a local computer problem, but I have run out of things to re-install, or try.
My app is a mobile app, but it is extremely convenient for me to use UWP for most of the work and for debugging.

Does anyone have any ideas on how I can get past this ?

Answers

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    Please close your VS, open your project folder, open all of your folder (xxx, xxx.Android, xxx.IOS, xxx.UWP), delete all of bin and obj folders like following screenshot. reopen your project by VS 2019, rebuild it, if this issue will disappear.

  • mthandmthand Member ✭✭

    Thank you for your help. I tried that, but that did not fix the problem, the same message occurs if I create a new app.
    It almost seems like I have a Windows issue causing a conflict with framework "Microsoft.VCLibs.110.00.Debug.UWPDesktop". I do not know what to do to get past this.
    But I do thank you for the help.

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    Please open the VS installer, found VS 2019, click the Repair

  • mthandmthand Member ✭✭

    Thank you for the help but I was not able to get this working, I think there was just something deep in Windows that was causing this. I ended up re-installing Windows, VS2017 and VS2019 and got things to work.

    It does seem that VS is moving away from UWP, or at least not making it easy. While I have no need to deploy in UWP, it sure is a lot nice and faster to do debugging in UWP.

    Thanks for the help.

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    Ok, thanks for your sharing.

Sign In or Register to comment.