Forum Xamarin.iOS

UIKit Broken - Error CS0246: The type or namespace name 'UIKit' could not be found

So i just update Visual Studio packages and then tried to run my app and UIKit has an error. Ive tried removing Xamarin.IOS and re adding it multiple times, and ive been scavenging the internet trying everything to fix this.

Is there anything i can do?

  • Thank you


  • LandLuLandLu Member, Xamarin Team Xamurai

    Xamarin iOS is bundled with Visual Studio, we can't separately update it.
    Try to check if Xamarin iOS has correctly installed on your PC.
    Create a new blank iOS project to see whether UIKit could be referenced.

  • BennyBooBennyBoo Member ✭✭

    I created a new test project and the UIKit worked so i don't know what the problem is with the project that UIKit isnt working

  • LandLuLandLu Member, Xamarin Team Xamurai

    Try to check the Xamarin iOS path you referenced in your project.
    How did you readd the Xamarin iOS library?

  • RicheyMBRicheyMB Member ✭✭

    Did you find a solution to this @BennyBoo ?

    Latest update to Xamarin.iOS introduced an error for me as it now performs a UIThreadCheck when instantiating objects.

Sign In or Register to comment.