Forum Xamarin.Forms

Unable to build iOS. ie "The application has not been built"

Hi,

I'm in VS for Mac version 8.7.3(build 13), recently i'm facing 2 issues.
1. Neither on simulator nor on device i can build iOS app. it says "This application has not been built".
2. Break point wont work on android.

Looking for some help.

Thanks..!

Best Answer

Answers

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    Please post completely error message.

    If you get the The application has not been built": Cannot deploy to different iOS simulators without closing and reopening solution
    If so, please uncheck "Enable device-specific builds" under Project Options > Build > iOS Build. This will allow you to deploy to different simulators

    Is you previous version worked as normal?

  • RaghavendraRaghavendra Member ✭✭

    yeah earlier it was working fine.
    "Enable device-specific builds" is also unchecked. But still i get the same error.

    No lengthy error as such, but it shows as attached.
    Attaching a screenshot.

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    Close VS, open you project folder , then open three folder(xxx, xxx.Android, xxx.iOS), delete the all of bin and obj folder.

  • RaghavendraRaghavendra Member ✭✭

    Yeah tried that as well.. No luck.. it didn't work..

    Found an error.
    Error: The 'MSBuild:UpdateDesignTimeXaml' code generator crashed: Not Connected

  • LeonLuLeonLu Member, Xamarin Team Xamurai
    edited August 27

    I seach this error, I found similar thread: https://github.com/xamarin/Xamarin.Forms/issues/10802

    What is your Xamarin forms nuget package version? please set xamarin forms nuget package version back to 4.7.0.1080 or Xamarin.Forms 4.6.0.967.

  • RaghavendraRaghavendra Member ✭✭

    i was on XF-4.4.0.991265, now i upgrade it to 4.6.0.967 as you told. But the issue still persists :neutral:

    Not sure whats really wrong...! All the above action item like deleting the 'bin' & 'obj' folders are done.. Upgraded to latest XF(4.8) as well. No luck

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    If you issue is still existed, you can open a support ticket(it is not free): https://support.microsoft.com/en-us/supportforbusiness/productselection?sapId=211dd84f-3474-c3c5-79bf-66db630c92a6

  • RaghavendraRaghavendra Member ✭✭
    Accepted Answer

    Hi LeonLu,

    Thanks for your time. :smile:
    Found the root cause for my issue.
    I was using "Xamarin.Google.iOS.Maps" Version (3.7.0.1) which was causing the issues. Just downgraded the plugin to 3.7.0 and the iOS project started compiling.

    iOS: 13.6

    https://github.com/amay077/Xamarin.Forms.GoogleMaps/issues/666

    Regards,
    Raghavendra GR

Sign In or Register to comment.