Forum Xamarin.iOS


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

CrossMedia.Current.TakePhotoAsync not returning from await, iOS13

patcarutherspatcaruthers USMember ✭✭✭

I'm up to date with everything - xamarin 8.7.3 (build 13), Xam.Plugin.Media 5.0.1

the code hasn't changed for many months and used to work, but now never gets to the "if (file==null)" statement:

    var file = await CrossMedia.Current.TakePhotoAsync(new Plugin.Media.Abstractions.StoreCameraMediaOptions {
            SaveMetaData = false,
            SaveToAlbum = false,
            PhotoSize = PhotoSize.Small,
            CompressionQuality = 50,
            DefaultCamera = CameraDevice.Rear

        if (file == null) {
            attachment = null;

Picking a photo from the library still works, but taking a picture does not.



  • LandLuLandLu Member, Xamarin Team Xamurai

    Have you tested the sample here:
    I run it on my iOS 13 device, it worked fine:

  • patcarutherspatcaruthers USMember ✭✭✭

    i'm trying to now, but am getting an error when i build -
    The type or namespace name 'App' could not be found (are you missing a using directive or an assembly reference?)
    2 Warning(s)

    i have updated the packages, but i don't know what directive or reference it is looking for.

  • patcarutherspatcaruthers USMember ✭✭✭

    ok, i got it to run with debug (i would still like to know how to solve the "missing reference" problem).

    yes, that sample is working on my iOS13 device, so there is something i'm doing that works with iOS12 but not iOS13 and i will have to find the difference between his code and mine. thx.

  • LandLuLandLu Member, Xamarin Team Xamurai

    Fell free to ask here if you have questions about it.

Sign In or Register to comment.