Forum Visual Studio

Why won't my iOS app deploy to the Simulator as a 4inch app?

ChaseFlorellChaseFlorell CAInsider, University mod

I'm using Stuart Lodge's FluentLayout for all of my Views. I've added all of the necessary App Icons including the ones for Retina.

The problem I'm experiencing is that when I Deploy/Debug to the simulator, the app always launches in a 3.5" screen. When I change the screen to 4" and re-launch the app, I get those pesky black bars on top/bottom.

Visual Studio isn't giving me any options to deploy to a 4" device.

Can anyone lend any help?

Answers

  • amilleramiller USXamarin Team Xamurai

    Hi @ChaseFlorell!

    I know there was an bug with the 4" simulator missing from VS. However, I think that issue should have been resolved in the current Alpha/Beta versions of the software. If you are able to update to those channels, I would recommend trying that out to see if the issue remains :)

  • ChaseFlorellChaseFlorell CAInsider, University mod

    Hello @AllieMiller, I ran the update, but I still see the same options in the DDL. When I deploy the app, it still runs in 3.5 mode. Is there an Info.plist setting that needs to be changed?

  • ChaseFlorellChaseFlorell CAInsider, University mod

    Still no answer from xamarin on this. /cc @AllieMiller

  • Andy_RobinsonAndy_Robinson GBUniversity ✭✭

    I also can't select a 4" simulator from VS although I can in Xamarin Studio. You can get rid of the black bars at the top and bottom though by including the correct size splash pngs for a 4" device.

  • ChaseFlorellChaseFlorell CAInsider, University mod

    Yep, I've removed the black bars with the splashscreen images, but the deploy is still not working.

  • PhilHarrisPhilHarris USMember

    I get the same problem. Basically, it does not enumerate correctly on the Visual Studio device selector
    iPhone (Retina) 7.0 - Always changes back to the 3.5 inch display.

    On the Simulator selector Hardware -> Device [iPhone Retina (3.5-inch), iPhone Retina (4-inch), iPhone Retina (4-inch 64bit), iPad etc....]

    Am running the latest Alpah / Beta etc ov everything.

  • DaveTDaveT DEMember

    I'm having the same issues using the latest Beta.
    iPhone (Retina) 7.0 selected in Visual Studio and the Simulator always switches back to the 3.5 inch device.

    Xamarin.iOS 7.0.7.2 (Business Edition)

  • aro2468aro2468 USMember

    Xamarin, any update on this?

  • aro2468aro2468 USMember

    BTW, I'm running the Beta version of Xamarin and still have the same problem

  • AbePleasantAbePleasant USMember ✭✭

    I'm also waiting to be able to select a 4" ios simulator from VS.

  • MarkRenwickMarkRenwick GBMember ✭✭

    I'm having the same problem with the latest Alpha, it's a real issues as changing hardware then running again just makes it switch back to 3.5

  • MarkRenwickMarkRenwick GBMember ✭✭

    Also just to mention I went to the alpha in the hope that it was fixed, stable has the same issue.

  • PhilHarrisPhilHarris USMember

    Simulator Selector - Xamarin Whats up ?
    1. I see I commented on this issue in Feb
    2. Running the latest Alpha
    3. Issue still exists - Not able to correctly enumerate the simulated devices on the iPhone
    4. Hence, unable to select a 4" IOS simulator
    5. Xamarin Studio does not exhibit the same behavior.

    Phil

  • JonasRembrattJonasRembratt SEUniversity ✭✭✭
    edited June 2014

    Same problem here.
    Any updates Xamarin?

  • billmurraybillmurray USMember

    Not much point having a forum if Xamarin aren't going to contribute to answering peoples issues.

  • PippoCanePippoCane USMember ✭✭

    Same problem here. Even the screenshot in this resource http://developer.xamarin.com/guides/ios/getting_started/installation/windows/introduction_to_xamarin_ios_for_visual_studio/ seems to suffer the same problem. Nothing new from xamarin?

  • rob_aglrob_agl USMember

    I was able to fix this issue by deleting the app off the physical device and then cleaning my solution.
    App then deployed in 4in mode.
    YMMV

  • ChadPitchfordChadPitchford USMember

    Fixed it in my project by adding a 4 inch Retina launch image ([email protected])

  • MikkelRostockMikkelRostock DKMember ✭✭
    edited September 2014

    Issue still there - I also fixed it in my project by adding a 4 inch retina launch image (640x1136)

  • I had the same issue. Adding a 4 inch launch image fixed it for me also.

Sign In or Register to comment.