Forum Xamarin.Mac

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Visual Studio & Xcode Not Playing Well Together

AllanChin.6924AllanChin.6924 USUniversity ✭✭✭

Visual Studio 8.7.1 (build 15) & XCode 11.6 (11E708) on MacOS 10.15.6.

When I open a storyboard with XCode Interface Builder from Visual Studio, I get all kinds of errors now.

And after closing all the error dialogs, I make my changes to the storyboard and Save. When I focus back to Visual Studio, I find that XCode, or somebody, has created a bunch of new file which I have to manually delete before building.

Anybody else seeing this? Is this a known issue and is planned to be fixed?

Thanks

Here's my environment.

=== Visual Studio Community 2019 for Mac ===

Version 8.7.1 (build 15)
Installation UUID: aaddbdd9-5a26-4ee5-abd9-1a5540d751e7
GTK+ 2.24.23 (Raleigh theme)
Xamarin.Mac 6.18.0.23 (d16-6 / 088c73638)

Package version: 612000090

=== Mono Framework MDK ===

Runtime:
Mono 6.12.0.90 (2020-02/d3daacdaa80) (64-bit)
Package version: 612000090

=== Roslyn (Language Service) ===

3.7.0-6.20371.12+917b9dfae12e3b6cb266a3c062fb20a1e9d5fb06

=== NuGet ===

Version: 5.7.0.6702

=== .NET Core SDK ===

SDK: /usr/local/share/dotnet/sdk/3.1.302/Sdks
SDK Versions:
3.1.302
3.1.301
3.1.300
3.1.202
3.1.200
3.1.102
3.1.100
3.0.101
2.1.700
2.1.4
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/6.12.0/lib/mono/msbuild/Current/bin/Sdks

=== .NET Core Runtime ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
3.1.6
3.1.5
3.1.4
3.1.2
3.1.0
3.0.1
2.1.20
2.1.19
2.1.18
2.1.17
2.1.16
2.1.15
2.1.14
2.1.11
2.0.5

=== Xamarin.Profiler ===

Version: 1.6.12.29
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Updater ===

Version: 11

=== Apple Developer Tools ===

Xcode 11.6 (16141)
Build 11E708

=== Xamarin.Mac ===

Version: 6.20.2.2 (Visual Studio Community)
Hash: 817b6f72a
Branch: d16-7
Build date: 2020-07-18 18:44:59-0400

=== Xamarin.iOS ===

Version: 13.20.2.2 (Visual Studio Community)
Hash: 817b6f72a
Branch: d16-7
Build date: 2020-07-18 18:45:00-0400

=== Xamarin Designer ===

Version: 16.7.0.492
Hash: f5afe667d
Branch: remotes/origin/d16-7-vsmac
Build date: 2020-07-10 18:42:54 UTC

=== Xamarin.Android ===

Version: 11.0.0.3 (Visual Studio Community)
Commit: xamarin-android/d16-7/aca845b
Android SDK: /Users/hpadmin/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
6.0 (API level 23)
7.1 (API level 25)
8.1 (API level 27)

SDK Tools Version: 26.1.1
SDK Platform Tools Version: 29.0.6
SDK Build Tools Version: 30.0.0 rc2

Build Information:
Mono: 83105ba
Java.Interop: xamarin/java.interop/[email protected]
ProGuard: Guardsquare/proguard/[email protected]
SQLite: xamarin/sqlite/[email protected]
Xamarin.Android Tools: xamarin/xamarin-android-tools/[email protected]

=== Microsoft OpenJDK for Mobile ===

Java SDK: /Users/hpadmin/Library/Developer/Xamarin/jdk/microsoft_dist_openjdk_1.8.0.25
1.8.0-25
Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Android SDK Manager ===

Version: 16.7.0.13
Hash: 8380518
Branch: remotes/origin/dev/jmt/d16-7readconfig~2
Build date: 2020-07-23 22:38:02 UTC

=== Android Device Manager ===

Version: 16.7.0.18
Hash: 4b44bc1
Branch: remotes/origin/d16-7
Build date: 2020-07-23 22:38:26 UTC

=== Build Information ===

Release ID: 807010015
Git revision: b2b8f289ffca8f28c585e9137d193c92462cbf14
Build date: 2020-08-07 10:38:31-04
Build branch: release-8.7
Xamarin extensions: b2b8f289ffca8f28c585e9137d193c92462cbf14

=== Operating System ===

Mac OS X 10.15.6
Darwin 19.6.0 Darwin Kernel Version 19.6.0
Thu Jun 18 20:49:00 PDT 2020
root:xnu-6153.141.1~1/RELEASE_X86_64 x86_64

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    This appears to be an IDE issue.
    Try to raise questions here:
    https://developercommunity.visualstudio.com/spaces/41/index.html
    Have you tried to open a new blank iOS application's storyboard? Or try to open the storyboard directly in the VS.

  • AllanChin.6924AllanChin.6924 USUniversity ✭✭✭

    Both IDEs work fine independently. It's the interaction between the 2 which is causing those issues. What do you mean by "directly in the VS"? I can open a storyboard with the "Source Code Editor" no problem which I resorted to doing for minor tweaks to the storyboard just to avoid those manifestations.

    Are you saying you do not see these issues under the same configuration?

  • AllanChin.6924AllanChin.6924 USUniversity ✭✭✭

    By the way, I just updated to Visual Studio 8.7.2 (build 4) and the XCode error and the creation of the new Base.lproj elements in the VS project is still happening.

Sign In or Register to comment.