Forum Visual Studio


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

error signing packages - apk ad hoc

NessaNessa DEMember ✭✭

Hey guys :blush:
So when I make an apk with archieve and everything and then release it AdHoc an error occurs.
After I put the Password in the certificate to put the apk on the Desktop(or wherever) it Fails.

There isn't popping up any message. the apk simply isn't where it should be. it's nowhere.
the sign on the right is red (normally it's green) and in the error row stands:
Error signing packages. The directory is not empty.
(German:Fehler beim Signieren von Paketen.Das Verzeichnis ist nicht leer. )
(As you can see in the pic)

In normal release and debug mode everything is working fine.
I work with Visual Studio 2017 and Friday this error occured and I can't find out why it doesn't work...
So the first was Ok but when I did it a second time (without changing anything in Code etc) this error occured.
I am sure that the Password for the certificate is right and the path in C: isn't too Long!

Plz Help! :cold_sweat:

BUT it's really strange. Now I can diestribute the apk's from the Archive liste from yesterday (which failed yesterday) just fine?
But it doesn't ask for my Password of the certificate?
But if I do a new one it Fails ._.


  • prashantvcprashantvc USXamarin Team Xamurai

    That's rather strange! Could you share the quick screen recording of the process? Or detailed steps to reproduce, I recommend using Step recorder

  • NessaNessa DEMember ✭✭

    I do it like it's recommended in Xamarin..,testing,_and_metrics/publishing_an_application/part_2-_signing_the_android_application_package/

    So i create my Project new and then i go on archieve all and VisualStudio then creates one in the archieves list. then i go to the Details Panel and distribute it... I do it Ad Hoc then I sign the apk and click on save as... i normally want to save it on my Desktop (but where doesn't matter i tried different locations) i enter my Password for the certificate and then... nothing.
    I check if it's on my Desktop but there is no apk and in the archives list is the red Symbol and the error message (just like in the picture)

    I dont know why this error appears because before it worked just fine

    I don't know which more Information you Need?
    as for the psr... i don't really know how to attach the mht? because that file is "not allowed"?

  • juyojuyo USMember ✭✭
    edited September 2018

    Signing packages failed.
    The directory is not empty.

    I have the exact same issue and I have no idea how I ended up with this errors.
    It used to be ok and at some point, I've got this errors.
    Anyone experience this issue??

    I cleaned the package and delete all bin and obj folder as well. still doesn't work

  • I'll bet my bottom cookie that it's because VS has unsaved changes to the keystore. Get out of all instances of VS, restart VS, reload your solution, clean the solution, archive. It will work...well, it did for me several times.

  • Buen día
    tengo el mismo problema enio el paso apaso

Sign In or Register to comment.