Forum Xamarin.Mac


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

'none of the currently installed provisioning profiles match the apps bundle id'

EmpiresOfLoreInXmFmsEmpiresOfLoreInXmFms Member ✭✭
edited June 2020 in Xamarin.Mac

I have been trying and failing to deploy my app under a Dev provisioning profile.

First thing to note is I develop on a PC, and I then copy the VS files to the mac, and then build on the Mac directly, although I could get the PC to pair to the mac, it drops out often, so I just figure that the mac is there, might as well open Visual Studio and work on the mac.

So my problem:
VS for Mac v 8.6.5 Build 23, Catalina and xamarin, all fully up to date 26/6/2020

In VS Mac, Build -> Archive for publishing -> Sign and Upload -> 'none of the currently installed provisioning profiles match the apps bundle identifier'

I believe my Mac has the correct signing certificate I have done this process a few times the cert in matches the developer cert on the Mac keychain certs

I have setup an App with an appropriate Bundle ID in, this matches the BundleID in the info.plist file

I created a dev provisioning profile in, downloaded it and installed in on the Mac

I use the same Bundle ID I use in Visual Studio for Mac, Xamarin iOS project. -> If I change this bundle identifier in info.plist and try to compile the project, it fails, but if I use the same one as above, the project compiles as expected. So BundleIDs match - all good! Code compiles!

However when: In VS Mac, Build -> Archive for publishing -> Sign and Upload ->
I get:
'none of the currently installed provisioning profiles match the apps bundle identifier'

If instead of trying to upload the file directly to apple from VS, I save the IPA file to disk and use Transporter to upload it:
I get:
'No suitable application records were found. Verify your bundle identifier is correct.'

Please note that when I look at the ios project properties in VS, under IOS bundle signing options, I see in the provisioning profile dropdown, the exact same provisioning profile that I had created in, and installed on the Mac. It is clearly visible in this drop down and I select it.

I have been round and round, deleting provisioning profiles from:

~/Library/MobileDevice/Provisioning Profiles/

And re generating them in reinstalling rebooting etc.. its killing me... :( round and round in circles..

If I examine the provisioning profle on disk at location ~/Library/MobileDevice/Provisioning Profiles/ it shows I have the correct certificate, and it shows me an appID (not bundleID)

The appID it shows is TeamID.BundleID, and this looks also 100% correct to match what is in info.plist, and what is in

The fact everything matches is subtly telling me that this is another bug in Visual Studio, any one have any ideas and or contacts that could help with this one.

My sanity is on the line and I am hoping someone out there has the ability to help out!

Best Answer


  • Hi @LandLu I did read this after posting this, and you are right thank you. So I switched to a adhoc distribution profile, and again I did the process a few times, but still always stuck on the sign and upload screen for the archives in vs on mac... I tried making a simple blank project in xcode directly with the same bundleID and this would not submit either but a message game back saying something like 'this is not a valid app store provisioning profile' ??? so then instead of distribution/adhoc, I created a distribution for upload to appstore, I managed one successful upload, somehow, at this point I was just relieved something worked, and having been in and out of xcode, vs, and transporter, i don't even know if it was from vs, transporter or xcode, bizzarly I think it was from xcode, and somehow even a test project seemed to pickup the icon of my main app, dunno how? but it never showed in the app store connect as a build. Also something that helped is that I only managed to upload it once I created an app in app store connect... however I cannot see the build online anywhere.. so I am still running around in circles today ....aaaargg.

  • LandLuLandLu Member, Xamarin Team Xamurai

    AdHoc is used to test your applications at release mode for registered devices.
    If you want to upload it to the App Store, App Store distribution profile is the only option.
    Try to create this kind of provisioning profile for your App ID and test it again.

  • yes am trying all this again will keep you posted. tx

  • Worked finally.

Sign In or Register to comment.