Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

iOS Simulator not working

Seb_GlanumSeb_Glanum Member ✭✭

Hello everyone,
I cannot open any iOS Simulator in Mac from my PC. The build was successful with no errors, but I notice that when i'm clicking again on the device to run,
instantly it stops the execution and then I can again click to run my app always saying that the deployment was successful.
I tried to delete bin and obj folders, reconnect to the Mac, change the simulator, restart VS.
I'm on the lastest version of Xamarin Forms and VS2019.

Do you have any ideas what I can do to make it work ?

Thanks !

Tagged:

Answers

  • Seb_GlanumSeb_Glanum Member ✭✭

    I forgot to say also I can run my app on real devices.

  • LandLuLandLu Member, Xamarin Team Xamurai

    Did you enable the Remote Simulator to Windows feature?
    If you use VS for Mac to run a simple project, could the simulator open successfully?
    Make sure the space on Mac is enough to deploy your Xamarin projects.
    If this issue persists, try to report a VS issue:
    https://docs.microsoft.com/en-us/visualstudio/ide/how-to-report-a-problem-with-visual-studio?view=vs-2019

  • Seb_GlanumSeb_Glanum Member ✭✭

    Hello @LandLu !
    I have enabled the Remote Simulator on Windows and my Mac has enough space.
    What is really interesting is that I have another app in which I can run iOS Simulators perfectly !

    Do you have something in mind that can help me to make run iOS Simulators ? Thank you !

  • Seb_GlanumSeb_Glanum Member ✭✭

    @LandLu And yes I can run simulators from VS for Mac but not from the remote simulator on Windows.

  • LandLuLandLu Member, Xamarin Team Xamurai

    Did this certain application throw some error messages?

    I have enabled the Remote Simulator on Windows and my Mac has enough space.

    This feature may fail when the connection is unstable. Try to disable it and test again.
    These instructions may help: Reboot the Mac, delete the bin/obj folders and redeploy.
    If you still can't open simulators, try to open a support ticket here:
    https://support.microsoft.com/en-us/supportforbusiness/productselection?sapId=211dd84f-3474-c3c5-79bf-66db630c92a6

  • Seb_GlanumSeb_Glanum Member ✭✭

    @LandLu No error just saying that the building is done, I have nothing else in return.

  • LandLuLandLu Member, Xamarin Team Xamurai

    We can't spot the issue with the information you provided.
    Try to open the free ticket with the link I posted above.

Sign In or Register to comment.