Forum Xamarin.Forms

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Cloud not launch Xamarin.Launcher

Dear all,

I am facing an issue with the launch iOS simulator.

The following image appeared when I tried to debug.

How can I fixed it?

Environment

  • macOS Catalina 10.15.4
  • Visual Studio for Mac
=== Visual Studio Community 2019 for Mac ===

Version 8.6 (build 4520)
Installation UUID: 436d9f64-9f6a-4a97-8b0c-f1f4848e6080
    GTK+ 2.24.23 (Raleigh theme)
    Xamarin.Mac 6.18.0.23 (d16-6 / 088c73638)

    Package version: 610000104

=== Mono Framework MDK ===

Runtime:
    Mono 6.10.0.104 (2019-12/5d03a6fe116) (64-bit)
    Package version: 610000104

=== Roslyn (Language Service) ===

3.6.0-3.20210.9+4eafdcb1bcbd8d3573f2ba6065e56d9b9ce4f8a3

=== NuGet ===

バージョン: 5.6.0.6591

=== .NET Core SDK ===

SDK: /usr/local/share/dotnet/sdk/3.1.300/Sdks
SDK バージョン: 3.1.300
MSBuild SDK: /Library/Frameworks/Mono.framework/Versions/6.10.0/lib/mono/msbuild/Current/bin/Sdks

=== .NET Core Runtime ===

ランタイム: /usr/local/share/dotnet/dotnet
ランタイム バージョン:
    3.1.4
    2.1.18

=== Xamarin.Profiler ===

バージョン:1.6.15.68
場所: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Updater ===

バージョン: 11

=== Apple Developer Tools ===

Xcode 11.5 (16139)
Build 11E608c

=== Xamarin.Mac ===

Xamarin.Mac not installed. Can't find /Library/Frameworks/Xamarin.Mac.framework/Versions/Current/Version.

=== Xamarin.iOS ===

Version: 13.18.1.31 (Visual Studio Community)
Hash: b3eedfed9
Branch: d16-6
Build date: 2020-04-09 10:22:36-0400

=== Xamarin Designer ===

Version: 16.6.0.329
Hash: d4f8bcd13
Branch: remotes/origin/d16-6
Build date: 2020-04-24 02:16:02 UTC

=== Xamarin.Android ===

バージョン:10.3.1.0 (Visual Studio Community)
コミット:xamarin-android/d16-6/3fe860a
Android SDK: /Users/toyoshima takumi/Library/Developer/Xamarin/android-sdk-macosx
    サポートされている Android バージョン:
        インストールなし

SDK Tools のバージョン: 26.1.1
SDK プラットフォーム ツールのバージョン: 29.0.5
SDK ビルド ツールのバージョン: 29.0.2

ビルド情報: 
Mono: 165f4b0
Java.Interop: xamarin/java.interop/[email protected]
ProGuard: xamarin/proguard/[email protected]
SQLite: xamarin/sqlite/[email protected]
Xamarin.Android Tools: xamarin/xamarin-android-tools/[email protected]

=== Microsoft Mobile OpenJDK ===

Java SDK: /Users/toyoshima takumi/Library/Developer/Xamarin/jdk/microsoft_dist_openjdk_1.8.0.25
1.8.0-25
Android Designer EPL のコードは以下から入手できます。
https://github.com/xamarin/AndroidDesigner.EPL

=== Android SDK Manager ===

Version: 16.6.0.50
Hash: 5901879
Branch: remotes/origin/d16-6
Build date: 2020-04-30 04:01:22 UTC

=== Android Device Manager ===

Version: 16.6.0.95
Hash: 45d17b5
Branch: remotes/origin/d16-6
Build date: 2020-04-30 04:01:42 UTC

=== Build Information ===

Release ID: 806004520
Git revision: 9c92c7baceef7771f8dcf5c86e1e1a66fdc26182
Build date: 2020-05-18 10:05:00-04
Build branch: release-8.6
Xamarin extensions: 9c92c7baceef7771f8dcf5c86e1e1a66fdc26182

=== Operating System ===

Mac OS X 10.15.4
Darwin 19.4.0 Darwin Kernel Version 19.4.0
    Wed Mar  4 22:28:40 PST 2020
    root:xnu-6153.101.6~15/RELEASE_X86_64 x86_64


Answers

  • imagolferimagolfer Member

    I'm receiving the exact same message. Started today (22 May 2020) when trying to debug iOS simulators. No simulators shown. Everything worked fine last night. I'm running Xamarin on Windows connected to a Mac running Catalina 10.15.4.

  • PrasanthKumarPrasanthKumar INMember ✭✭

    Am also facing the issue since yesterday 22-May-2020 and unable to debug/deploy the apps on iPhones, with VS 2017 or with VS 2019.
    But, The framework version I have is different than showing in the screenshot - 13.16.0.13

  • toyoc_xamarintoyoc_xamarin Member

    I will share the results of following trials.

    • Delete Visual Studio using dotnet-uninstall-pkgs.sh and uninstall-vsmac.sh
    • re-install Visual Studio
    • Rebooting OS

    Didn't work :(

    • Delete Visual Studio and settings file using AppCleaner.
    • re-install Visual Studio

    Didn't work :(

    • Use the another solution file

    Didn't work :( This message box is appeared when I open the solution file.

    • When finished install of Visual Studio, I confirmed mlaunch.exe on following path .
    • /Library/Frameworks/Xamarin.iOS.framework/Versions/13.18.1.31/lib/mlaunch/mlaunch.app/Contents/MonoBundle
    • When I debugged it seemed that mlaunch.exe was deleted.
    • When I used FortiAppMonitor to track the file deletion, I got the following output:
    {
      "recid": 2124,
      "time": "1590216389.891536933",
      "eventType": "File Delete",
      "process": "mlaunch",
      "pid": 55364,
      "user": "**********",
      "message": "Delete file: /private/var/folders/6_/8tv11_nn2f7ggj20k45mk9l0s93bc4/T/CASESENSITIVETESTd3c2a0c0475a4a768035c5a1868a9260",
      "extra": "{\"parent process\":\"VisualStudio\",\"ppid\":50290,\"uid\":848407940}"
    }
    

    I'm currently copy-pasting mlaunch.exe to avoid it.

  • BillFultonBillFulton AUMember ✭✭

    Same. Message box pops up continually until VS force-killed.

  • LukSLukS Member

    Short term fix
    Dragged Visual Studio and Xamarin Profiler to the trashcan.
    Delete the folder /Library/Frameworks/Xamarin.iOS.framework from finder
    Reinstall VS

    After reinstall of VS the Xamarin.iOS.framework folder is recreated including the mlaunch.exe
    I'm currently testing write protecting the mlaunch.exe, I can still run VS but I fear for updates in the future.

    MacOS, VS for Mac v 8.6 (build 4520)

  • prashantpurmahprashantpurmah Member
    edited May 2020

    Started experiencing this issue after restarting my mac. Tried downgrading VS for mac, Xamarin.iOS and .NET Core but to no avail.

    On top of the issues mentioned above, the simulators stopped appearing on Visual Studio with the message "lower the deployment target to see older simulators or check your apple SDK path"

    Workaround:
    In my case, it was the antivirus deleting mlaunch.exe. So for now, I have removed the Xamarin.iOS.Framework folder from those that need to be scanned and reinstalled Xamarin.iOS.

  • LukSLukS Member

    @prashantpurmah said:
    In my case, it was the antivirus deleting mlaunch.exe. So for now, I have removed the Xamarin.iOS.Framework folder from those that need to be scanned and reinstalled Xamarin.iOS.

    You found the culprit,
    my Symantec logs a Heur.AdvML.B virus and delete the file.

    The question remain, is the file actually infected or is the antivirus overacting?

  • imagolferimagolfer Member

    I just upgraded to 13.18.1.31 and added the folder \Library\Frameworks\Xamarin.iOS.framework\Versions to the exclude list in Norton 360. Just hours after installing, I checked Norton's logs and it deleted mlaunch.exe because it was identified as being infected with Heur.AdvML.B.

  • MichelangeloFrancoMichelangeloFranco ITUniversity ✭✭✭
    edited May 2020

    Me too, Think Symantech is the problem.
    Everything works fine and when I try to rerun n debug my solution for check the update I made to the code I start to get this error. Check the activity in Symantec and found that a couple of minute ago it delete the mtouch.exe cause infected with Heur.AdvML.B.....

    I set the Symantec that don't scan the Library/Framework folder.

    I also contact the Symantec Help Desk and inform of the problem.

    In my case the solution was delete the /Library/Frameworks/Xamarin.iOS.framework and reinstall VSMAC checking the option of Xamarin.IOS

  • muthinenimuthineni Member

    I have same problem with Symanteh , Microsoft need to fix the infection name - Her.AdvML.B in the mlaunch.exe file . I have to manually repair and copy this file back to iOS path to get it working ..

    This is the actual path.
    /Library/Frameworks/Xamarin.iOS.framework/Versions/13.14.1.39/lib/mlaunch/mlaunch.app/Contents/MonoBundle/mlaunch.exe

  • MattRobbMattRobb GBUniversity ✭✭

    I had the same problem, Symatech had deleted the file. I set it as an exclusion and re-downloaded VS. However the path still didnt exist. Just to make sure Symantech wasnt interfering I disabled it for a time. Then I re-installed VS. BTW I am using a Mac. I still get the same issue even after the downloads. I can see the path /Library/Frameworks/Xamarin.iOS.framework/Versions/13.14.1.39/lib/mlaunch/mlaunch.app and if I inspect the contents of the MonoBundle there is no mlaunch.exe. In simple terms I am stuck! Is this file part of VS, or part of Xamarin or is it part of NetCore. I have run out of ideas.

Sign In or Register to comment.