Forum Xamarin.Mac


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Broken Xcode's "Assistant Editor" in Xamarin fresh install

GalloGallo Member ✭✭

Hello Guys,

I've just installed Xamarin, Xcode and started to follow the tutorial at "[...] microsoft [...] /get-started/hello-mac" but I've got stuck with a broken "Assistant Editor" at Xcode storyboard. I've tried a few tips after googling, but nothing worked.

I was wondering if there is a way to continue the tutorial... :-/

What do you suggest?



  • GalloGallo Member ✭✭

    Just as an (frustrated) update -- moved to another Mac and it seems that the integration between Visual Studio for Mac (8.5.2)/Xamarin.mac with Xcode 11.4 (11E146) is broken. There are two errors:

    -- an internal inconsistency appears when opening Storyboard: "The NSMenuItem with object ID kIP-vf-haE had an incorrect action connection 'toggleSourceList:', which was replaced with 'toggleSidebar:'. Please check for uses of toggleSourceList: and toggleSidebar: in your project to verify that the correct IBAction method is called, and;

    -- the assistant editor does not work on the interface builder when called from VS.

    Anyone with the same issue? Are there any workarounds?

    I am new to Xamarin...

    Thank you!

  • LandLuLandLu Member, Xamarin Team Xamurai

    Is this a fully new blank project?
    Have you tried to open this storyboard file directly in XCode?
    It seems some controls on the storyboard missed compatibility.

  • GalloGallo Member ✭✭

    Thank you for your feedback LandLu

    However, opening directly on Xcode didn't work. Same inconsistency:

    And Assistant Editor not working:


  • ChrisHamonsChrisHamons USForum Administrator, Xamarin Team Xamurai

    As this is IDE integration related, please open an issue on developer community with details. That will be the fastest route to someone taking a look at this who's on the correct team.

  • GalloGallo Member ✭✭

    Thank you ChrisHamons. I've just done that. I will reference back I a manage to get something there.

  • MichaelBothMichaelBoth AUMember ✭✭✭

    @Gallo, I think I've found your report here:

    I'm experiencing the same problem, so will observe any developments with interest.

  • ChrisHamonsChrisHamons USForum Administrator, Xamarin Team Xamurai

    Thanks for the report folks. Does anyone have a project that reproduces this that they could include?

  • GalloGallo Member ✭✭

    Sure. Please find it attached. 352.3K
  • MichaelBothMichaelBoth AUMember ✭✭✭

    I see they've updated the bug report:
    "A fix for this issue has been internally implemented and is being prepared for release. We'll update you once it becomes available for download. "

    Great news!

Sign In or Register to comment.