Forum Cross Platform with Xamarin

CarouselView problem on UWP

I have a weird problem about CarouselView. There is only an image in my CarouselView.ItemTemplate > DataTemplate. I download some pngs in my code and define ItemsSource of CarouselView from this downloaded streams. It works great in Android and IOS.. Weirdly in UWP always first photo is blank. What could be causing this?

Answers

  • jezhjezh Member, Xamarin Team Xamurai

    For CarouselView problem on UWP ,you can ask on website of : https://github.com/windows-toolkit/WindowsCommunityToolkit/issues

  • JohnHardmanJohnHardman GBUniversity mod

    @Esege said:
    I have a weird problem about CarouselView. There is only an image in my CarouselView.ItemTemplate > DataTemplate. I download some pngs in my code and define ItemsSource of CarouselView from this downloaded streams. It works great in Android and IOS.. Weirdly in UWP always first photo is blank. What could be causing this?

    Post your relevant XAML/C#. Without that, people won't be able to identify an issue in your code that might be causing the symptom that you describe.

    Note also that according to https://forums.xamarin.com/discussion/179085/current-release-xamarin-forms-4-5-0#latest , CarouselView is still in Preview (i.e. it's not considered stable, production quality yet). It's therefore certainly possible that there are issues in CarouselView on UWP (new features tend to be stabilised on UWP later than one Android and iOS).

    If you think you've found a defect in the Xamarin.Forms.CarouselView implementation, log an Issue in Github

Sign In or Register to comment.