VS 2019 v16.4.5 -> XCode 11.3 on remote build machine -- story boards won't render

I am completely new to the iOS side of things, but have been working with Xamarin for about a year. I simply set things up as the come out-of-the-box from reading online, but please let me know if I went wrong somewhere.

VS 2019 on Windows connects to my Mac Mini just fine, and provisioned / updated some versions there. Connection is made and all is happy. Prior, I loaded VS 2019 on the Mac, XCode and command line tools, and Mono.

In VS 2019 on Windows, I select a new mobile iOS app and allow VS to build out the scaffolding. Click on the storyboard, LaunchsScreen.storyboard, and either the spinner just spins forever and never renders anything or I see, "This file could not be upgraded to the correct format automatically and so cannot be opened. If Xcode is correctly configured then re-saving the file in Xcode may resolve the issue." Oddly enough, I can compile and run the app--the simulator shows a blank, black window which seems right for an empty storyboard, but again, new to the Mac side of this...

I tried adding a new sotryboard--same result. An empty storyboard won't render, and therefore, I am unsure how to be able to build one out. I was hoping to use the Mini Mac as a remote build machine and stay within Windows, but I can't get this to work....

I've been looking for a solution for more than an hour with no luck. If someone can point me in the right direction, I would be grateful. I have a significant non-forms Xamarin Android app that is needing it's iOS counterpart built out.

Thank you, kindly!

Answers

  • HamittirpanHamittirpan Member ✭✭✭✭

    @rdowens11vx Is the problem storyboard appearing as a black screen? If this is the problem have you tried adding a View Controller from Toolbax by doing CTRL + Alt + X after deleting the storyboard and adding a new storyboard?

  • rdowens11vxrdowens11vx Member ✭✭

    Just tried this....

    I deleted the old, empty storyboard. I added new item: view controller with storyboard. Double clicked the new storyboard, and the exact same result: Mac Mini hard-drive makes a bunch of noise for a while (so it's doing something), and VS 2019 in Windows just shows a progress bar with a green rectangle that's making endless circuits (assuming that 5+ minutes should be enough time to render something....

    I do appreciate the help.

  • LandLuLandLu Member, Xamarin Team Xamurai

    What's the version of your Visual Studio and XCode?
    There will be a format issue if you used incompatible Visual Studio and XCode:
    https://developercommunity.visualstudio.com/content/problem/880058/xcode-is-too-new-2.html
    Have you tried to open this storyboard on VS for Mac? The loading will also be caused by an unstable connection.

  • rdowens11vxrdowens11vx Member ✭✭

    My versions are in the title of my post:

    VS 2019 v16.4.5 -> XCode 11.3 on remote build machine -- story boards won't render

    I see by the post you directed me to, that these versions, although the newest, don't work together.

    I will see if I can load an older Xcode...

    Thank you.

  • rdowens11vxrdowens11vx Member ✭✭

    Downloaded Xcode 10.3. Mac seems to have two versions now: 11.3 and 10.3....

    Finder loads version 11.3 from applications. Downloads has 10.3. Command tools for 10.3 won't load because the OS is too new. I have no idea how to tell VS 2019 on Windows how to use the older version of Xcode, and I'm not sure how to make the 10.3 the default. My guess is that it won't work anyway because the command tools won't load on this version of the OS.

    I thought Macs were supposed to be easy.... Nothing about any of this has been easy. 8 hours into my Xamarin for iOS journey and nothing but frustration.

    I appreciate everyone's kind advice and time. If anyone knows how to make this mess work, I would be grateful.

  • LandLuLandLu Member, Xamarin Team Xamurai

    I didn't realize your title has indicated the version information.
    The 13.3 XCode and 16.4.3 Visual Studio worked for me. I haven't updated the Visual Studio to the latest yet. I will try it later.
    If you move this application to your Mac. Could this storyboard be opened by VS for Mac? It seems the storyboard file's format messed up on your VS.

  • rdowens11vxrdowens11vx Member ✭✭

    Thanks, LandLu!

    This is just a brand new project with an empty storyboard created from selecting new project in Visual Studio. It creates a launcher and main storyboard and neither will render. Note that these are untouched by me: these are the empty files that VS creates.

    I tried a Xamarin forms project as well. The Android emulator renders the MainPage.xaml but the iOS emulator just spins. However, doing a compile and run: it works fine on both emulators. It is only a problem at design-time. The designer simply doesn't render for Xamarin iOS or Xamarin Forms for the Mac side for me with my versions.

    Everything I have is newly installed with no prior versions or patching as possible issues.

    Opening the same new project on the Mac side works fine. The Mac

Sign In or Register to comment.