Forum Libraries, Components, and Plugins


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Adding Xamarin.Google.iOS.SignIn results in a native linking error (MT5209)



  • MarkWheelerMarkWheeler USMember

    I am using the most current version of Xamarin Studio Community Edition on a Mac running Mac OS Sierra (v 10.12.3). The method documented below has worked for me now a few different times on different solutions where I have experienced this issue with Xamarin.Google.IOS.MobileAds.

    Here are the steps that worked for me to resolve this issue:

    1. Remove all occurrences of the "Xamarin.Google.IOS.MobileAds" package in your solution.

    2. Remove all occurrences of the "Xamarin.Build.Download" package in your solution.

    3. If you have multiple projects in your solution, and more than one will use the "Xamarin.Google.IOS.MobileAds" package, then select one and repeat the following for each other project in your solution:

      1. Click on the "Project" menu and select "Add NuGet Packages..."
      2. Enter "Mobile Ads" in the search box and add the most current version of "Google APIs Mobile Ads IOS Library".
      3. Enter "Build Download" in the search box and add the most current version of
        "Xamarin Build-time Download Support".
    4. Click on the "Build" menu and select "Clean All"

    5. Right click on each solution and choose "Rebuild << project name>>" for each project and your project should link.

    Hope this helps others who are having the same issue !

  • BillHolmesBillHolmes USXamarin Team Xamurai

    VS 2017 has changed enough to break Xamarin Build Download. We are testing some fixes in 0.4.3 and hope to release later this week. Please try the pre-release.

  • ruborubo USMember ✭✭
    edited March 2017

    @BillHolmes I have this problem too with VS 2017. It happens with the latest Xamarin.Build.Download 0.4.3-beta5. I have to do Clean All each time I need to run the project. Super annoying. Please address this, guys.

  • BillHolmesBillHolmes USXamarin Team Xamurai

    @rubo beta6 resolves an issue where incremental builds resulted in linker errors. You had to rebuild each time. I agree it was a super annoying bug.

    We are getting close to the release to the release of 0.4.3. Please continue to ping me on the Forums if you see issues.

  • ruborubo USMember ✭✭

    @BillHolmes Thanks. With beta6, the issue is gone.

    There's another and less annoying issue with Google.iOS.Maps package related to this one. By default, it installs the Xamarin.Build.Download 0.2.2. And if your project is project.json based (cause it references a .NET Standard lib project), you don't see the Xamarin.Build.Download in the installed packages list as it's not a direct dependency. Given this, I have to manually change the required version of Xamarin.Build.Download in the .nuspec file of Google.iOS.Maps package. Are you going to address this too?

  • BillHolmesBillHolmes USXamarin Team Xamurai

    @rubo, Yes, we plan to bump all of the versions of NuGets that require XBD. I want this to happen in the coming days after we release XBD to stable.

    re: project.json: Can you just add the specific XBD version to your project throught the package manager dialog?

  • ruborubo USMember ✭✭

    @BillHolmes I wasn't sure that Google.iOS.Maps would pick up the version if I'd installed it manually.

  • gustavolima.7435gustavolima.7435 USMember ✭✭

    Getting Same Error

  • sachinJsachinJ INMember ✭✭
    edited December 2017

    i'm trying to impliment Native google sign in in iOS
    i downloaded "Xamarin.Google.iOS.SignIn" package from nuget
    this package depends one "Xamarin.Build.Download.0.4.7"
    now when i run project getting error while build, it gives below error
    "Xamarin.Build.Download.0.4.7\build\Xamarin.Build.Download.targets(54,3): error : Object reference not set to an instance of an object."

    Note - this issue only for iOS project. in android i successfully implimented google plus sign in

    i checked solutions but not able to fixed issue.
    anyone please help.

  • LuizNegriniLuizNegrini USMember ✭✭

    Error: Did not find reference matching RestoreAssemblyResources AssemblyName metadata 'Google.SignIn, Version=, Culture=neutral, PublicKeyToken=null' (dragon.iOS)

    I have this error here and I have a version of Xamarin.Build.Download 0.7.1

    I believe it should be fixed so that it does not break AppCenter automated builds for example, because if you have to make any changes to files generated by the build, this new problem will happen. Does anyone know how to solve?

  • I am currently using Xamarin Studio, I was able to build and run the sample by itself, the problem I'm having is when I want to use parts of the sample for my own personal project.

  • I had the same problem and it was resolved when I followed MarkWheeler's instructions above. I had previously updated Xamarin.Build.Download to version 0.8.0 and after reinstalling the Xamarin.Google.iOS.SignIn package, Nuget installed Xamarin.Build.Download version 0.4.11 and that's when it started working.

Sign In or Register to comment.