Storyboard Broken In Latest Update?

fehro84fehro84 USMember ✭✭

I've had this issue for days now and it's driving me crazy.

I have two Macs, one I updated and it start to cause this to happen then I updated the next one yesterday and it's also happening.

I am using VS 2015 on Windows to develop (with a Mac build server).

The problem I am having is the storyboard (even in a new project) has started to auto size my controls when adding constraints to the same size as the old red outlined ghost shape that you used to get (sorry if that doesn't make sense). Some screen shots will explain it better.

Screen 1 - I have a view, I add a text box and I want to for example pin it's sides to the main view. So I am about to pin the right side (also why is the edge now inside the view?)

I pin the right side and almost immediately this happens. On my slower mac I can sometimes quickly pin the left side too before the view updates but I mean seriously that is not a solution. I can't resize it or anything now, just keeps reverting back to the same size until I remove the constraints again.

This isn't normal behavior is it? It's been a few months since I did iOS dev and I swear this didn't used to happen. All I can think of trying now is rolling back Xamarin on the mac to an earlier version as that did used to work :( This is a serious break in it's functionality. As in the storyboard editor is useless.


  • PatrykRomanczukPatrykRomanczuk PLMember ✭✭

    Honestly if you want to stay sane and not lose your hair due to the storyboard editing madness - use XCode.

  • fehro84fehro84 USMember ✭✭

    I see your point! Thanks!

  • JakovljevicIgorJakovljevicIgor USMember ✭✭✭

    Is this getting a fix. The same thing happens to me also, I cannot use the storyboard at all, I lost one element in the storyboard. Imagine trying to find a collection view in a collection view cell.

    Not cool at all Xamarin!!!

  • fehro84fehro84 USMember ✭✭

    I fixed it. Not sure which step it was that did it but this is what I did. Also I don't know if all the steps are neccessary. I'm not sure if it was the lower version of Xcode or the Xamarin iOS software itself that fixed it.

    Rolled back Xcode to 8.2.1.
    Deleted Xamarin from my pc and mac build server.
    Installed the latest version of Visual Studio on Mac from the Xamarin site.
    Installed the previous release of Xamarin iOS from on my Mac (to downgrade the newer version).
    Installed Xamarin for Visual Studio from

    Then it started working again perfectly. Except the storyboard gets a bit stuck updating. Have to keep mashing the 'Update Frames Based On Constraints' button. But at least I could finish the changes required.

    Lesson learned: Turn off automatic Xcode updates on the Mac and don't upgrade Xamarin unless you're prepared to roll it all back. Igor do you know about the Document Outline window? I only just discovered it, it makes selecting an element that's not rendering in the view properly very easy (e.g. off to the side or behind another element).

  • rvlirarvlira BRMember ✭✭

    I'm getting the same problem.

    I tried to follow the instructions given by @fehro84 above without any luck. Even though I installed Xamarin for Visual Studio, when I try to build the project I get "This version of Xamarin.iOS requires the iOS 10.3 SDK (shipped with Xcode 8.3) when the managed linker is disabled. Either upgrade Xcode, or enable the managed linker by changing the Linker behaviour to Link Framework SDKs Only".

    Also, when I try to open a storyboard it gives me "This file has been edited in a version of Xcode which is unsupported by the designer. Documents saved in Xcode 8.2.1 format, or older, are supported."

    That's a show stopper. I looked into Xamarin's bugzilla but this hasn't been reported yet. I was going to open an issue but there are a lot of information required. Some of which I'm not even sure what to fill. I'll look again later...

    I was going to try to use XCode to edit the storyboard but I've got a lot of incompatibilities error in the past (tried last week again with no luck).

    In my case, seems like I'm gonna have to go back to create everything by code.

  • fehro84fehro84 USMember ✭✭
    edited May 2017

    I did also get that error about the storyboard had been edited in a newer version as I was mucking about trying to get it working with the newer version still installed and saved. But I could just revert back to the previous revision of my storyboard as I hadn't actually changed anything useful.

    Have you installed the lower version of Xamarin iOS on your mac? See in my screenshot it wants to update to 10.10.0 (because I have the manually installed version

  • swizzyswizzy CHMember ✭✭
    edited May 2017

    Hi fehro84

    its work perfectly :-) And your solution even helped me with another problem, with breakpoint not hit :-)

    thanks! :-)

  • fehro84fehro84 USMember ✭✭

    @rvlira thanks for logging the bug but. Hopefully they fix it soon.

    Happy I helped @swizzy

  • swizzyswizzy CHMember ✭✭
    edited May 2017

    I also have the error that I could not open the storyboards and the .xib files. Xcode version error.
    I then found one, which I could open set the xcode version as with the one that had worked.

    document type="" version="3.0" toolsVersion="11762" systemVersion="16C68" targetRuntime="iOS.CocoaTouch" propertyAccessControl="none" useAutolayout="YES" useTraitCollections="YES" colorMatched="YES"

    plugIn identifier="" version="11757"/

  • rvlirarvlira BRMember ✭✭

    @swizzy Thanks! That worked. I was installing Xamarin Studio for Windows to see if the error happens there aswell. But that did the trick.

    @fehro84 I haven't reported the bug yet but I'll try to do it later today. They ask a lot of questions, some of which I'm not even sure how to answer.

  • JeffGonzalesJeffGonzales USMember ✭✭

    @swizzy I can't get breakpoints to hit in iOS either. I downgraded Xamarin.iOS on my build agent per the link above but when I try to do the same thing on my development machine it complains that I don't have Visual Build Tools 2015 installed. I'm using 2017 and really cannot downgrade. I can't find the 2016 build tools installer either.

    Is there a better way to get my breakpoints back?

  • JeffGonzalesJeffGonzales USMember ✭✭

    Setting debug option to "portable" seems to be working for me so far:

  • ChrisColeTechChrisColeTech USMember ✭✭✭

    story board is broken is latest Xamarin.iOS 11

    dont go to xcode 9 yet, if possible.

  • MichaelPliamMichaelPliam USMember ✭✭

    VS 2019 Xamarin IOS (Win 10) MacBook Pro Main.storyboard is working, but only on initial new project. Any subsequent compile breaks the storyboard with error message "...Xcode too new". What gives?

Sign In or Register to comment.