Can't debug my libraries with XF - symbols not loaded for my own project code

I cannot step through my own project libraries referenced by my Xamarin Forms app. All my Nuget packages are showing symbols loaded - I can step through any library code except for my own! I have tried including these projects in my Xamarin forms solution; I have tried removing them from the solution also. (My modules always show "symbols not loaded" in the Modules window during debugging.) I have tried deleting bin folders, specifying the folder where the pdb file is in my debug options, changing my debug settings in every different way imaginable. I can step through these libraries (my code/projects) with no problems when running my WPF application, but can't from my Xamarin forms app. These are my own libraries (.NET Standard 2.0 - same as my Xamarin forms project.) Any suggestions are appreciated. I have spent hours on this and can't get past it.

Answers

  • joannerayejoanneraye Member ✭✭
    edited January 13

    Wow, I was so hoping this would help, but changing the standard library to pdb only and full (tried both) did not work. Thanks for the suggestion though! What's interesting is that Visual Studio seems to be able to find the source code because the breakpoint is solid red (not with an exclamation point as if it can't set the breakpoint), so the breakpoints are set but when the code in my Xamarin Forms .NET Standard project gets to the statement that would call the other library, I get the blue arrow that means it "cannot go there" and then it goes to the next statement in my Xamarin Forms code. (I have breakpoints set in the library but it doesn't step into the code.) Modules Window shows the symbols are not loaded and I have tried loading from there and helping it find the pdb files to no avail. (Like I said I can step through the library fine from my WPF project - the library is in the one location and referenced from my WPF project as well as the Xamarin Forms project. Xamarin Forms cannot step through it neither when debugging with the emulator or with an Android device.) By the way I am using Visual Studio 2019 Professional version on a Surface Book machine.

    I am going to try Visual Studio repair using the Installer. See if that helps.

  • joannerayejoanneraye Member ✭✭

    Deleted bin and obj folders, ran repair on Visual Studio. Did not help.

Sign In or Register to comment.