Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Deploy to iOS simulator only results in black screen

TomasWesterlundTomasWesterlund SEMember ✭✭
edited December 2019 in Xamarin.iOS

I use Windows 10 and rent a Mac through MacInCloud (Dedicated for admin privileges).

Visual Studio (from Window) connects correctly but when I try to deploy my application to an iOS simulator the actual simulator appear but it's only a black screen. I created an empty Xamarin project but without any success.

I added break points to Supports multiple windows but it doesn't seem to be called either.

Below is a screenshot from VS:

From the iOS Simulator:

Mac:
OS Catalina 10.15
XCode 11.2.1
VS 8.3.11

What can one do to get more information of the root cause of this (as I don't see any error message anywhere)?

Tagged:

Best Answer

Answers

  • TomasWesterlundTomasWesterlund SEMember ✭✭

    @ColeX said:
    Some suggestions :

    • Upgrade everything to the latest (VS for mac , VS for windows , XCode ).

    • Restart PC and visual studio .

    • Delete bin and obj folder on windows side.

    • Reconnect mac agent .

    • Clean and rebuild .

    • Change simulator(iPhone X e,g)

    • Disable remote simulator to Windows (Tools - Options - Xamarin - iOS Settings)


    If problem persists , attach your build log here (Help - Xamarin - Open Logs).

    Thanks for your reply!

    When disabling "Remote Simulator" I can see it on the Mac, which is fine for now. I just thought you would be able to show it through the iOS Simulator in Windows.

    I appreciate your help!

  • ColeXColeX Member, Xamarin Team Xamurai
    edited December 2019

    @TomasWesterlund said:

    @ColeX said:
    Some suggestions :

    • Upgrade everything to the latest (VS for mac , VS for windows , XCode ).

    • Restart PC and visual studio .

    • Delete bin and obj folder on windows side.

    • Reconnect mac agent .

    • Clean and rebuild .

    • Change simulator(iPhone X e,g)

    • Disable remote simulator to Windows (Tools - Options - Xamarin - iOS Settings)


    If problem persists , attach your build log here (Help - Xamarin - Open Logs).

    Thanks for your reply!

    When disabling "Remote Simulator" I can see it on the Mac, which is fine for now. I just thought you would be able to show it through the iOS Simulator in Windows.

    I appreciate your help!

    The steps before disable Remote simulator also work on windows , if they don‘t work ,i'm afraid you have to show it on mac.

Sign In or Register to comment.