Android device doesn't appear in Visual Studio 2017 as deployment option

SvetoslavHlebarovSvetoslavHlebarov USMember ✭✭✭
edited November 2019 in Xamarin.Android

I am creating Xamarin.Android project in Visual Studio 2017 Community edition. My device is ZTE Blade A452, my computer's operating system is Windows 7. I downloaded the driver for ZTE Blade, run its .exe, and followed the steps from the following link:

Then I followed the steps from Install USB Drivers part from the following link:

In both cases a message said something like: "Your driver has been updated succesfully" but Visual Studio 2017 still doesn't show the device name as a deployment option. I have looked at questions on internet related to that topic but every answer said something different and complex to do. And as the answers had to do with system administration(installing, uninstaling things on Windows) rather than with programming(which is the thing I control more) I was worried to take any actions fearing that I would make things worse and irreversible. My question is, is there more simple solution to my problem? My other question is why deployment on a real device has to be so dificult, a part from programming I have to do things related to Windows etc. ?


  • JarvanJarvan Member, Xamarin Team Xamurai

    Please make sure that you've enabled the "USB Debugging" feature on your phone, try the following steps to debug the device.

    • Unlock your phone and go to Settings.
    • Under Settings, scroll down and open About phone.
    • Find Build Number and tap seven times on it
    • Tap Developer option ->select USB Debugging to enable it


  • SvetoslavHlebarovSvetoslavHlebarov USMember ✭✭✭
    edited December 2019

    I have enabled USB Debugging in my phone. But it still doesn't appear as a deployment option.

  • JarvanJarvan Member, Xamarin Team Xamurai
    edited December 2019

    Try to Restart Adb Server: Tools -> Android -> Restart Adb Server.

Sign In or Register to comment.